Jump to content


Photo

Tdci 2006 Mondeo Engine problems


  • Please log in to reply
2 replies to this topic

#1 Bobx1x

Bobx1x

    Newbie

  • New Member
  • Pip
  • 4 posts
  • Ford Model: 2006 Mondeo Tdci 130
  • Location:

Posted 19 November 2009 - 07:59 PM

I own a 2006 130 tdci 67,000mls i have had it since new.
It has been serviced on time and uptill now no problems have occured.
However it now is starting to hold on to the engine speed when changing up or down the gearbox it holds at about the 2000rpm mark and on occasions will accelerate slightly when attemting to use engine breaking.

I have cleaned the Egr and Manifold, as advised by mintalkin but still this problem persists.
:angry:
What signs and symtoms do Knackerd injectors have on the engine. and are these likely to cause this problem, if so , does anybody know of a supplier other than ford.

Thanks in aticipation of your help.

Dave (bobx1x)

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 peanuts

peanuts

    Member

  • New Member
  • PipPip
  • 23 posts
  • Ford Model: 03 mondeo tdci 130
  • Location:

Posted 19 November 2009 - 11:05 PM

Know ford want 200+vat per injector then need coding 80+
you could try pfjones of stretford 01618724755 126+vat for recon or 168+vat fitted & coded
good luck

#3 Blackwhite

Blackwhite

    Member

  • New Member
  • PipPip
  • 13 posts
  • Ford Model: Mondeo MK3
  • Location:

Posted 20 November 2009 - 12:44 PM

It looks like Turbo problems not Injectors.Check intercooler pipe there is no leaks.
Usualy if injectors are knackedr you will see "spring" led flashing.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users