Jump to content


Escort Problems?

  • Please log in to reply
1 reply to this topic

#1 Adam_E



  • New Member
  • Pip
  • 1 posts
  • Ford Model: Escort 1.8TD
  • Location:

Posted 20 November 2009 - 01:56 PM

I just bought a P Reg 1.8TD with 62000 miles clocked. I can't hear or feel the turbo working, and the MPG is quite low at 40ish. The car hasn't been driven much over the last few years as it's an ex company car, and it seems to start only after ticking over a few times or second time, with quite a rattle when it eventually gets going. Can anyone help out with these small priblems and what i can do to fix them. My mechanical skills are limited, but prognosis's would be very helpful. Cheers for the help in advance. Ad

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 vinnyvangough


    Ford Enthusiast

  • Moderator
  • 2,329 posts
  • Name: Steve
  • Ford Model: 2003 Focus TDCi, Escort Mk6 RS2000, Mk2
  • Year: 2003
  • Location: Devon

Posted 20 November 2009 - 07:21 PM

Hi, the starting problem could be that it needs to have the glo-plugs changed.

If i was you i'd start by giving her a full service and the turbo's are usually quite quiet on these unless you do what i done and added an atmospheric wastegate and upped the boost.

Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users