Jump to content


Show
Photo

Mondeo Mk 3 Central Locking


  • Please log in to reply
8 replies to this topic

#1 Pogo

Pogo

    Member

  • New Member
  • PipPip
  • 25 posts
  • Ford Model: Mondeo
  • Location:

Posted 20 November 2009 - 09:56 PM

Hi,
After some help or advice. I have a MK3 mondeo and the central locking has stopped working on the left hand rear door. Is this a common fault? Is it likely to be the door itself or the drivers door as I know this controls the whole system.

Cheers for any help given

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,461 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 21 November 2009 - 05:21 PM

first things to check would be the wiring at the rear door piller for damage and remove the rear door card to check for any broken connectors or rods.

#3 Pogo

Pogo

    Member

  • New Member
  • PipPip
  • 25 posts
  • Ford Model: Mondeo
  • Location:

Posted 22 November 2009 - 10:29 AM

first things to check would be the wiring at the rear door piller for damage and remove the rear door card to check for any broken connectors or rods.

Done all that, motor doesn't move when I operate remote or the drivers door lock.

#4 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,461 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 22 November 2009 - 02:14 PM

are you getting power to the door motor ?

#5 Pogo

Pogo

    Member

  • New Member
  • PipPip
  • 25 posts
  • Ford Model: Mondeo
  • Location:

Posted 22 November 2009 - 06:31 PM

I tested this with a multi meter and when I operated the key it quickly flicked to 12v, but I've no idea how long its supposed to stay for or if the flick of the voltage is enough to operate the door lock mechanism

#6 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,461 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 23 November 2009 - 02:52 PM

it sounds like a sticking or faulty central door lock motor or mechanism..try a good lube around the mechanism if that does not work you might need a new motor.

#7 Pogo

Pogo

    Member

  • New Member
  • PipPip
  • 25 posts
  • Ford Model: Mondeo
  • Location:

Posted 23 November 2009 - 04:52 PM

Hi,
Thanks for the help, I'll give it a try.

#8 InstructorPiggy

InstructorPiggy

    Too much time on the boards

  • New Member
  • PipPipPipPip
  • 981 posts
  • Ford Model: Fiesta Mk7 TDCI ZS

Posted 23 November 2009 - 05:17 PM

Motor definitely, only takes a shot of 12v to get one of them working.

They are fairly universal things, shouldn't be too pricey, find one second hand easy enough.

Piggy :)

#9 KarlZ

KarlZ

    Newbie

  • New Member
  • Pip
  • 4 posts
  • Ford Model: Mondeo MK2
  • Location:

Posted 04 January 2010 - 08:10 PM

I have the same problem on the front passenger door.. the central locking doesnt work on that door.. It can be annoying at time if you carry passengers.. but since I drive around alone its no fuss :D


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users