Jump to content


Photo

brake problems


  • Please log in to reply
2 replies to this topic

#1 Domz78

Domz78

    Member

  • New Member
  • PipPip
  • 11 posts
  • Ford Model: escort van 1.3 petrol
  • Location:

Posted 30 November 2009 - 02:53 PM

hi every1 i own a mk4 escort van 1.3 petrol i have replaced front discs pads rear shoes etc but my brake pedal has hardly any pressure and barely stops van it sinks to the floor there is no leaks from rear hubs so i think the rear cylinders are ok could this be master cylinder????? much apreciate any help oh yea if i pump pedal it builds pressure but then soft again

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 stef123

stef123

    Ford Enthusiast

  • Management
  • 5,878 posts
  • Name: Stefan
  • Ford Model: Mondeo ST TDCI
  • Year: 2006
  • Location: Scotland
Contributor

Posted 30 November 2009 - 05:40 PM

sounds like you may have burst a seal in the master cylinder, i presume these problems started right after you changed the disc/pads etc?

did you remove the cap from the fluid resevoir when pushing the pistons back?

#3 InstructorPiggy

InstructorPiggy

    Too much time on the boards

  • New Member
  • PipPipPipPip
  • 981 posts
  • Ford Model: Fiesta Mk7 TDCI ZS

Posted 30 November 2009 - 05:42 PM

yea, did you have problem before the work you did?


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users