Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


gilles27

Flashing light on dashboard

8 posts in this topic

Hi all, I have a problem with my Focus (2002 TDCi) which I would appreciate some help with. Sometimes, after driving for 5 or 10 minutes, the glow plug indicator light on the dashboard starts flashing and the engine suffers a reduction in power. If I restart the car, the problem goes away.

According the manual, "if the light flashes when driving, it indicates a malfunction". I'd like to know if this means a problem with the glow plugs (i.e. one or more need replacing) or something else altogether. My understanding of the glow plugs is that they are only used when the car is started, after that they are not used. This makes me think that something else is wrong.

I'd appreciate any suggestions, especially from others who have had the same experience.

Thanks,

Ross

Share this post


Link to post
Share on other sites
 

Hi all, I have a problem with my Focus (2002 TDCi) which I would appreciate some help with. Sometimes, after driving for 5 or 10 minutes, the glow plug indicator light on the dashboard starts flashing and the engine suffers a reduction in power. If I restart the car, the problem goes away.

According the manual, "if the light flashes when driving, it indicates a malfunction". I'd like to know if this means a problem with the glow plugs (i.e. one or more need replacing) or something else altogether. My understanding of the glow plugs is that they are only used when the car is started, after that they are not used. This makes me think that something else is wrong.

I'd appreciate any suggestions, especially from others who have had the same experience.

Thanks,

Ross

MY mate has a mercedes c class had a similar problem

we thought like you the glow plugs only work before starting

On the mercedes they thay have 2 stages one for starting then when running they come on again untill the car warms up (to do with the emiisions) they keep the manifold warm

his car had a fault on the control unit so they were not comming on after the car had started same sort of warning light

we could not understand why the glow plugs came on the car started OK then the warning light came on after it was running

may be the Focus has similar system some one may know more than me

Share this post


Link to post
Share on other sites
Hi all, I have a problem with my Focus (2002 TDCi) which I would appreciate some help with. Sometimes, after driving for 5 or 10 minutes, the glow plug indicator light on the dashboard starts flashing and the engine suffers a reduction in power. If I restart the car, the problem goes away.

According the manual, "if the light flashes when driving, it indicates a malfunction". I'd like to know if this means a problem with the glow plugs (i.e. one or more need replacing) or something else altogether. My understanding of the glow plugs is that they are only used when the car is started, after that they are not used. This makes me think that something else is wrong.

I'd appreciate any suggestions, especially from others who have had the same experience.

Thanks,

Ross

Could be a few things. If it has a fuel filter with only 2 pipes and an electrical sensor it is most likely the fuel filter needs changing. But if they flash and the enging stops it is something more serious. One point here though, before you take it to get the diagnostic code read, make sure the fault warning light is on. Normally the fault has to occur twice before it will lock in an error code!

Share this post


Link to post
Share on other sites

the glow plug light covers many issus...it is an indicator that you have a problem.Idealy it should go to a dealer with the correct IDS equipment for accurate diagnosis.YYou ned to go to a dealership at some point to cler the fault codes and havethe light put out.

Share this post


Link to post
Share on other sites

Could be the Mass Air Flow sensor. The best way to find out is get a laptop diagnostic.

Neil

Share this post


Link to post
Share on other sites

Hi all, I have a problem with my Focus (2002 TDCi) which I would appreciate some help with. Sometimes, after driving for 5 or 10 minutes, the glow plug indicator light on the dashboard starts flashing and the engine suffers a reduction in power. If I restart the car, the problem goes away.

According the manual, "if the light flashes when driving, it indicates a malfunction". I'd like to know if this means a problem with the glow plugs (i.e. one or more need replacing) or something else altogether. My understanding of the glow plugs is that they are only used when the car is started, after that they are not used. This makes me think that something else is wrong.

I'd appreciate any suggestions, especially from others who have had the same experience.

Thanks,

Ross

Had the Same problem but had read somewhere that iy can be the injectors losing code... Rang my fuel Injection Specialist who recoded the system that was 25k ago been fine ever since now at 150k

Share this post


Link to post
Share on other sites

Hi, new to the forum. Have spent many hours trying to find an answer but no joy so I'm hoping someone here can help?

Jumped in on this topic as I can't seem to start a new one yet.

Anyways, message i light flashed red on my 2009 Focus 1.6TDCi Zetec for about a minute whilst driving. There were no messages at the time and none in the message memory when I checked later. It may have occurred shortly after I restarted too quickly from a stall. No other warning lights. Just a glitch or a warning to take seriously? Thanks.

Share this post


Link to post
Share on other sites

I have a flashing red light on the dashboard on the left side of the radio of my ford fiesta, didn't even notice there was a light there before. Recently added oil and had the battery charged as I left my lights on yesterday, any know what this is, or if there is any connection to the battery being recharged. Car running fine but this light is not going off.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now