Jump to content


Photo

diesel injection pump


  • Please log in to reply
5 replies to this topic

#1 colinr

colinr

    Newbie

  • New Member
  • Pip
  • 6 posts
  • Ford Model: escort 55 van
  • Location:

Posted 05 December 2009 - 03:42 PM

Hi I am having starting problems with my 1800 escort diesel van 51 plate
Been told it may be the injection pump not sure yet so I thought I will get a second hand pump if this turns out to be the problem. But I have now been told that if I fit a second hand pump from another van it will not work as they are coded to the engine.
Can any one tell me if this is correct if so is there a way round this.
Thanks

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 InstructorPiggy

InstructorPiggy

    Too much time on the boards

  • New Member
  • PipPipPipPip
  • 981 posts
  • Ford Model: Fiesta Mk7 TDCI ZS

Posted 05 December 2009 - 05:48 PM

Depends if it is mechanical injection or electronic...not sure on that age, is it a turbo??

You sure it needs a pump...what else has been tried??

Piggy :)

#3 colinr

colinr

    Newbie

  • New Member
  • Pip
  • 6 posts
  • Ford Model: escort 55 van
  • Location:

Posted 05 December 2009 - 06:12 PM

Depends if it is mechanical injection or electronic...not sure on that age, is it a turbo??

You sure it needs a pump...what else has been tried??

Piggy :)


Hi. I have put on new starter motor, glow plugs, battery, primer pump,
Oil, fuel and air filters. Its fine when running but the longer I leave it the
Harder it is to start.
(non turbo)

#4 rustneversleeps

rustneversleeps

    Settling In Well

  • Budding Enthusiast
  • PipPipPip
  • 30 posts
  • Ford Model: escort van 1.8D 2001
  • Location:

Posted 06 December 2009 - 03:11 PM

Hi. I have put on new starter motor, glow plugs, battery, primer pump,
Oil, fuel and air filters. Its fine when running but the longer I leave it the
Harder it is to start.
(non turbo)


Really feel for you colinr,having the same problem with mine on a Yplate,but must say that I,ll bin mine before replacing all that gear you have.Thank christ Ive got a back up.

Attached Thumbnails

  • 006.JPG


#5 colmac1

colmac1

    Member

  • New Member
  • PipPip
  • 10 posts
  • Ford Model: Fiesta SI 1.6 16V EFI 1995
  • Location: Scotland

Posted 13 December 2009 - 09:17 PM

Hi I am having starting problems with my 1800 escort diesel van 51 plate
Been told it may be the injection pump not sure yet so I thought I will get a second hand pump if this turns out to be the problem. But I have now been told that if I fit a second hand pump from another van it will not work as they are coded to the engine.
Can any one tell me if this is correct if so is there a way round this.
Thanks


hi there i had the same prob with my 75 escort van and i took 1 off my donner van 55 it still works but if ur low if in diesel it takes more effort to start. before u start it pump it from the diesel pump till its hard then it will fire up thats what i do every morning.

#6 rustneversleeps

rustneversleeps

    Settling In Well

  • Budding Enthusiast
  • PipPipPip
  • 30 posts
  • Ford Model: escort van 1.8D 2001
  • Location:

Posted 13 December 2009 - 09:24 PM

hi there i had the same prob with my 75 escort van and i took 1 off my donner van 55 it still works but if ur low if in diesel it takes more effort to start. before u start it pump it from the diesel pump till its hard then it will fire up thats what i do every morning.


Colmac1 what do u mean pump it till its hard and from where (under the bonnet?)



cheers and thanks.................ers51

Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users