Jump to content


Photo

characteristics or faults


  • Please log in to reply
3 replies to this topic

#1 dingdongdo

dingdongdo

    Member

  • Budding Enthusiast
  • PipPip
  • 25 posts
  • Name: lee
  • Ford Model: mondeo tdci 1.8
  • Year: 2009
  • Location: Northamptonshire

Posted 07 December 2009 - 09:06 PM

can you help?
i have just bought a 3yr old zetec 130tdci from a ford forecourt which was supposedly given the full service and multi-point check over etc. its going back in on weds to have a very difficult gear change looked at. but has other issues too....... as mentioned gear selection is very difficult when cold (extremely so for reverse), also if i select gears 5 or 6 then the gear stick does not spring back to the central position without a push as every other car always has. also the handbrake lever comes very high (almost hits centre console). and theres more..... when its cold and wet outside the climate control struggles to keep the windows from misting up (this also has never been a problem with previous cars). are these mondeo characteristics or faults as i have had various similar cars from ford rivals over the years and had none of these issues. was i silly to think the most popular family saloon car in this country should be stress free???? p.s. its done 51k with most history and is under warranty.

thanks lee.

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 jellyman

jellyman

    Settling In Well

  • New Member
  • PipPipPip
  • 44 posts
  • Name: Bob
  • Ford Model: mk3 mondeo tdci 130
  • Year: 2003
  • Location: Somerset

Posted 08 December 2009 - 02:01 AM

The misting may simply be due to a blocked pollen filter and the handbrake problem may be that the cable is seized at the rear wheel calliper

#3 InstructorPiggy

InstructorPiggy

    Too much time on the boards

  • New Member
  • PipPipPipPip
  • 981 posts
  • Ford Model: Fiesta Mk7 TDCI ZS

Posted 08 December 2009 - 09:31 AM

amen to the above and sounds like an iffy gearbox there...could just be low oil, and the gears not going back to neutral could either be the gears or cables....

Sounds like general wear n tear grimes really from a Ford...its letting you know who made it! :)

Did you by any chance own Jap cars before!?

Piggy :)

#4 dingdongdo

dingdongdo

    Member

  • Budding Enthusiast
  • PipPip
  • 25 posts
  • Name: lee
  • Ford Model: mondeo tdci 1.8
  • Year: 2009
  • Location: Northamptonshire

Posted 08 December 2009 - 09:16 PM

thanks for the replies, will update when i get it back from ford, my recent previous cars were, rover 75, zafira, vectra and piccaso. none of these cars had the problems i now have with the mondeo. to be fare the car is quick and has good spec so if these problems get sorted then i am looking forward to trouble free motoring..... or am i being foolish ? lee.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users