Jump to content


Show
Photo
- - - - -

Sluggish and slow


  • Please log in to reply
3 replies to this topic

#1 dizz

dizz

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: Fiesta 1995 1.3
  • Location:

Posted 21 June 2008 - 05:10 PM

Hi all

Ive got a 1995 1.3 Fiesta Sapphire which i recently bought. It was fine for the first couple of weeks but has since started making an annoying whistling noise whilst revving and it is very sluggish getting from 30-60 mph. Its not the clutch slipping - i had that replaced today. I dont know whats causing it to be so slow. Sometimes when im trying to speed up the car judders back and forth, and it takes at least 20 seconds to speed up by 10 or 15 mph.

its far too slow for a 1.3

please help!

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 Steve

Steve

    Administrator

  • Admin
  • 4,938 posts
  • Ford Model: Kugy
  • Location: Dorset
Contributor

Posted 22 June 2008 - 08:35 AM

was it always sluggish since you bought it?

#3 dizz

dizz

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: Fiesta 1995 1.3
  • Location:

Posted 22 June 2008 - 10:55 AM

no it was fine when i bought it - its only recently the lack of speed has happened. I didnt do anything to the car or drive it badly to make it sluggish.

#4 Steve

Steve

    Administrator

  • Admin
  • 4,938 posts
  • Ford Model: Kugy
  • Location: Dorset
Contributor

Posted 23 June 2008 - 12:27 PM

best bet would be to take it to have a diagnosis machine put on to see whee the problem lies. You could do this outside of ford.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users