Jump to content


Photo

lacking power


  • Please log in to reply
4 replies to this topic

#1 craig_y2k2008

craig_y2k2008

    Member

  • New Member
  • PipPip
  • 11 posts
  • Ford Model: escort
  • Location:

Posted 01 January 2010 - 06:20 PM

i`ve just had a escort mk6 1.6 1995`and its lacking power it seems to have a flat spot in the revs from about 3500 revs to about 5500 any ideas wot could be wrong with it ,thanks craig

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 InstructorPiggy

InstructorPiggy

    Too much time on the boards

  • New Member
  • PipPipPipPip
  • 981 posts
  • Ford Model: Fiesta Mk7 TDCI ZS

Posted 02 January 2010 - 12:12 PM

millage?

last service?

any modifications?

Does it pick up then after 5500rpm?

does it change depending on weather?

Piggy :)

#3 craig_y2k2008

craig_y2k2008

    Member

  • New Member
  • PipPip
  • 11 posts
  • Ford Model: escort
  • Location:

Posted 02 January 2010 - 06:07 PM

millage?

last service?

any modifications?

Does it pick up then after 5500rpm?

does it change depending on weather?

Piggy :)

yeah its better after that its just a flat spot in the revs its holding back quite abit its standard apart from a cone air filter , i,ve just fitted the performace exhaust and cat off my old car and its abit better but still not performing how it should my old escort with the same engine was alot quicker oh and its done 71000 and got service history and dont know if it changes if weather is diff as i`ve only had the car 2 days any idea`s on wot it could be would be a great help

#4 InstructorPiggy

InstructorPiggy

    Too much time on the boards

  • New Member
  • PipPipPipPip
  • 981 posts
  • Ford Model: Fiesta Mk7 TDCI ZS

Posted 02 January 2010 - 10:35 PM

2000rpm of lack of power is a bit more than a flat spot! :lol:

I would suggest (and is what I would do) to return the mods to standard and see if still the same.

:)

#5 craig_y2k2008

craig_y2k2008

    Member

  • New Member
  • PipPip
  • 11 posts
  • Ford Model: escort
  • Location:

Posted 05 January 2010 - 02:07 PM

2000rpm of lack of power is a bit more than a flat spot! :lol:

I would suggest (and is what I would do) to return the mods to standard and see if still the same.

:)

it was standard when i had it i,ve put some redex in in and gave it a good thrashing and its loads better now


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users