• Get Your Club gear
      Get Your Club gear
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Join Premium & Save
      Join Premium & Save
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Share Your Car Experience
      Share Your Car Experience

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


bt_cav

Fusion Front heated windscreen

27 posts in this topic

Thanks for the picture guide, my connections seem ok, but maybe the nearside one was a tiny bit loose. Have re-connected and will see in the morning if cold enough if it has made any difference. 

Share this post


Link to post
Share on other sites
 

Here are today's findings - drivers side connector was a bit loose, and there is also a small tear? Is this the cause of the fail? can't tell today as not cold enough.

And why is damp getting in the car - hang on if you remove the rain drain from the end of the scuttle - the screen rubber has a gap - is this causing a problem? Should it be like that?

close up.jpg

arrow window.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now