• Get Your Club gear
      Get Your Club gear
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Share Your Car Experience
      Share Your Car Experience
    • Join Premium & Save
      Join Premium & Save

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


chrispilko

Focus 1.4 mk2

Recommended Posts

Hi all, 

I have my 2005 1.4 ford focus mk2 and it needs attention asap. The car is very sluggish to accelerate especially on a hill. I know they came out of the factory with sluggish acceleration but my car seems like it wants to hold back when foot is pressed to the floor. I have replaced plugs and coil-pack and still no improvement, the ht leads look in good shape so i didn't bother with them. The car has also failed nct due to emission problems so i have come to the conclusion that the egr valve may need a serious clean considering the old spark plugs were in an awful state. The car was scanned with diagnostics and no codes were present. Anyway, I can't locate the egr valve though so if anyone could help it would be appreciated, 

Thanks in advance.

ford.jpg

Share this post


Link to post
Share on other sites
 

You say the ht leads 'look in good shape' have you actually checked them with a meter?

Share this post


Link to post
Share on other sites
11 hours ago, Russ said:

You say the ht leads 'look in good shape' have you actually checked them with a meter?

 I will borrow some from a different ford focus today and let you know. Any idea to where the egr valve is located?

Share this post


Link to post
Share on other sites

Have you changed the fuel filter. If it was me I would look at that as you have done the other main common easy fixes.After that I would change the o2 sensors and look at the MAF sensor in as much as find a known good unit and try that . I could be completely wrong in this but with it not having a turbo would it not have an EGR valve?  

Any how hope you get it sorted 

Regards Adam

Share this post


Link to post
Share on other sites

The 1.4 petrol Focus doesn't have an EGR valve fitted so that's definitely not the issue. Also the petrol does not have a fuel filter, only the diesels.

You say you have changed the spark plugs and coil pack but not the leads. I would definitely recommend changing the leads, if the set is starting to go bad it can make a surprisingly big difference to the performance of the car. Also they are cheap to replace so that would be my first port of call.

When removing the leads look down and see is there any water/coolant in between the spark plugs. This is a well known issue with the 1.4 Focus which will cause a big drop in performance and or hesitation also. I have suffered this problem along with many others on the forum.

Share this post


Link to post
Share on other sites

http://www.eurocarparts.com/ecp/c/Ford_Focus_1.4_2005/p/car-parts/filters/engine-parts/fuel-filters/?503590188&1&34792f53dfb82763eeb63721b34db6a1a50ed24f&000140

This is the first place I would start its on the drivers side near the rear jacking point.

 

Regards Adam

Share this post


Link to post
Share on other sites
On 8/22/2017 at 11:00 AM, ace666 said:

Have you changed the fuel filter. If it was me I would look at that as you have done the other main common easy fixes.After that I would change the o2 sensors and look at the MAF sensor in as much as find a known good unit and try that . I could be completely wrong in this but with it not having a turbo would it not have an EGR valve?  

Any how hope you get it sorted 

Regards Adam

Hi, i replaced the ht leads and no difference. However i got some stp injector cleaner and held the revs to 2.5k and sprayed some through a spray bottle into intake butterfly valve and it had a drastic performance increase.The car pulls now when i put my foot to the floor but slightly holding back still at higher revs. I am going to try cataclean today because i got a very good deal on a bottle of it (snake oil) and i suspect a blocked cat. I will keep everyone updated anyway so thanks.

Share this post


Link to post
Share on other sites
On 8/22/2017 at 11:00 AM, ace666 said:

Have you changed the fuel filter. If it was me I would look at that as you have done the other main common easy fixes.After that I would change the o2 sensors and look at the MAF sensor in as much as find a known good unit and try that . I could be completely wrong in this but with it not having a turbo would it not have an EGR valve?  

Any how hope you get it sorted 

Regards Adam

I am going to replace fuel filter today also. I will ask my brother about maf and o2 sensors as he is a mechanic. I will keep everyone updated, cheers.

Share this post


Link to post
Share on other sites
On 8/22/2017 at 11:26 AM, Dave_TDCI said:

The 1.4 petrol Focus doesn't have an EGR valve fitted so that's definitely not the issue. Also the petrol does not have a fuel filter, only the diesels.

You say you have changed the spark plugs and coil pack but not the leads. I would definitely recommend changing the leads, if the set is starting to go bad it can make a surprisingly big difference to the performance of the car. Also they are cheap to replace so that would be my first port of call.

When removing the leads look down and see is there any water/coolant in between the spark plugs. This is a well known issue with the 1.4 Focus which will cause a big drop in performance and or hesitation also. I have suffered this problem along with many others on the forum.

Changed leads and had my flashlight on but couldn't see any liquid down there. However when i replaced the plugs they were cracked and in an awful state so i replaced them with Bosch super 4's. Cheers anyway.

Share this post


Link to post
Share on other sites

Hi all,

first of all sorry if my english is bad.

 

I have same problem with my Focus 1.4 petrol 2006, same like on the picture in first post. On the hill is very lazy, on idle it is shaking and like missfires.

I have changed coil-pack two times, last one is NGK, spark plugs 3 times now is NGK also, and spark leads also NGK, I have changed throttle body (used), for 2 years I have changed 3 fuel pumps (all of them stoped working) etc etc

Sometimes it shows some faults on diagnostic, my fruiend cleared them. Now it doesnt show any faults but still work same.

I dont know what more to do, it is problem for 1 or 2 years and I cant find the solution.

Can someone please help me. please.

Someone said before about MAF and fuel filter as I know this model doesnt have those

Thanks everyone

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now