Jump to content


Show
Photo

mondeo mark 2 central locking fault


  • Please log in to reply
6 replies to this topic

#1 Bazst

Bazst

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Ford Model: fiesta ST
  • Location:

Posted 01 July 2008 - 08:38 AM

hi my dad is having a problem with his car the central locking has stopped working had a look around and found the fuse was blown replaced the fuse but keeps blowing does anyone have any ideas please


thanks very much

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 the controller

the controller

    Settling In Well

  • New Member
  • PipPipPip
  • 65 posts
  • Ford Model: mondeo

Posted 11 July 2008 - 08:35 AM

hi my dad is having a problem with his car the central locking has stopped working had a look around and found the fuse was blown replaced the fuse but keeps blowing does anyone have any ideas please


thanks very much


You must have a short circut somewhere start by looking at the wiring loom the comes out of the A pillar to the doors, pull the trunking back and checks for broken or bared wire, if they look good check the wring to the door latches by removing the door cards, you mave have a seized latch causing a problem?

#3 Supahoopsa

Supahoopsa

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: 99 Monde0 2.0 Zetec
  • Location:

Posted 11 September 2008 - 04:12 PM

My CL has also packed up recently and is also blowing fuses.

However there is a constant ticking noise coming from somewhere near the drivers footwell - sounds like a relay triping. This clicking also coincides with the red led alarm light next to the clock flashing so I assume that this is related??

Any ideas as to how or where I start with trying to fix this?

#4 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,463 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 12 September 2008 - 10:07 AM

check as previous post for your c/locking,the relay i think is a different issue and might just be noisy

#5 Supahoopsa

Supahoopsa

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: 99 Monde0 2.0 Zetec
  • Location:

Posted 12 September 2008 - 10:18 AM

check as previous post for your c/locking,the relay i think is a different issue and might just be noisy


thanks, but I have visually checked the wires and they look OK.

The relay clicking, the LED blinkinging and the Central locking blowing a fuse all happened at the same time so I am convinced that this is the route cause of my problem.

I stuck my head under the footwell last night and there are wires everywhere, just above the pedals. There is a definite ticking noise coming from there!

Any ideas?

#6 Rikos

Rikos

    Too much time on the boards

  • New Member
  • PipPipPipPip
  • 857 posts
  • Ford Model: Fiesta 1.4 LX

Posted 12 September 2008 - 12:07 PM

Have you checked the earth?

Nothing like hijacking a thread :P

#7 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,463 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 12 September 2008 - 01:18 PM

this might help


http://www.mirez.co.uk/AlarmProbs.htm

Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users