• Share Your Car Experience
      Share Your Car Experience
    • Get Your Club gear
      Get Your Club gear
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Join Premium & Save
      Join Premium & Save
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members


Bazst

mondeo mark 2 central locking fault

7 posts in this topic

hi my dad is having a problem with his car the central locking has stopped working had a look around and found the fuse was blown replaced the fuse but keeps blowing does anyone have any ideas please

thanks very much

Share this post


Link to post
Share on other sites
 

hi my dad is having a problem with his car the central locking has stopped working had a look around and found the fuse was blown replaced the fuse but keeps blowing does anyone have any ideas please

thanks very much

You must have a short circut somewhere start by looking at the wiring loom the comes out of the A pillar to the doors, pull the trunking back and checks for broken or bared wire, if they look good check the wring to the door latches by removing the door cards, you mave have a seized latch causing a problem?

Share this post


Link to post
Share on other sites

My CL has also packed up recently and is also blowing fuses.

However there is a constant ticking noise coming from somewhere near the drivers footwell - sounds like a relay triping. This clicking also coincides with the red led alarm light next to the clock flashing so I assume that this is related??

Any ideas as to how or where I start with trying to fix this?

Share this post


Link to post
Share on other sites

check as previous post for your c/locking,the relay i think is a different issue and might just be noisy

Share this post


Link to post
Share on other sites
check as previous post for your c/locking,the relay i think is a different issue and might just be noisy

thanks, but I have visually checked the wires and they look OK.

The relay clicking, the LED blinkinging and the Central locking blowing a fuse all happened at the same time so I am convinced that this is the route cause of my problem.

I stuck my head under the footwell last night and there are wires everywhere, just above the pedals. There is a definite ticking noise coming from there!

Any ideas?

Share this post


Link to post
Share on other sites

Have you checked the earth?

Nothing like hijacking a thread :P

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now