• Share Your Car Experience
      Share Your Car Experience
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Get Your Club gear
      Get Your Club gear
    • Join Premium & Save
      Join Premium & Save
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale


Edd1971

Indicator issues

Recommended Posts

My wife's 2001 ka has developed an issue with the indicators, it is still in very good condition only covered 30k. Basically they don't work but the hazards do , I've changed the fuses the switch and even the steering column stalks. It can't be a bulb issue as I said earlier the hazards work fine. The green arrows on the dash do not light up though. I'm literally at a loss. Any advice would be great thanks. 

Share this post


Link to post
Share on other sites
 

11 minutes ago, Edd1971 said:

Excuse my ignorance but where would I find the relay.. 

I've found the relays but how do I determine which one is for the indicators . Apologies for the daft questions 

Share this post


Link to post
Share on other sites

Indicator relays will click when engaged, same as front & rear wipers (& headlights also I believe).
Process of elimination should work or remove each relay in turn and test-




Sent from my SM-G930F using Tapatalk

Share this post


Link to post
Share on other sites

Thank you so for your help.. I've now solved the problem it was fuse 22 I did change this first off but it must of been faulty from the box. I purchased it from Halfords brand new but it was obviously faulty. Again thank you all.

Sent from my SM-G930F using Tapatalk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now