• Share Your Car Experience
      Share Your Car Experience
    • Get Your Club gear
      Get Your Club gear
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Join Premium & Save
      Join Premium & Save
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale


Sign in to follow this  
Followers 0
marshy2312

help needed

5 posts in this topic

hey guys i have a mark 1 focus t plate now the problem is il be driving down the road and all of a sudden the speedo will go off and the car will lack on power but will still drive if i come to a set of traffic lights it will cut out it will then start back up off the key first turn but speedo remain off and still lacking it only seems to be realy happening if the weathers isnt very good or dull day. wat i have tried ive pulled nearly every plug i can find around the engine and put grease in these hoping this would stop i havent touched the fuse box just 2 big connecters under neath also my fuel gadge has now gone on the blink

Share this post


Link to post
Share on other sites
 

hey guys i have a mark 1 focus t plate now the problem is il be driving down the road and all of a sudden the speedo will go off and the car will lack on power but will still drive if i come to a set of traffic lights it will cut out it will then start back up off the key first turn but speedo remain off and still lacking it only seems to be realy happening if the weathers isnt very good or dull day. wat i have tried ive pulled nearly every plug i can find around the engine and put grease in these hoping this would stop i havent touched the fuse box just 2 big connecters under neath also my fuel gadge has now gone on the blink

yuneed to take it to ford it could be the instrument cluster is on its way out a new one fitted only costs 99quid after so many complaints on watchdog or it could be the speed sensor to the gearbox

Share this post


Link to post
Share on other sites

Could be the idle control valve but its more common if the speedo is dropping for it to be the Vehicle Speed Sensor.

Share this post


Link to post
Share on other sites

would this cause it to lack on power wen the speedo goes off its seems to me as if im driving with no battery the battery light does come on wen the speedo stops working but only wen i come to a stop also where do i find the gear box sensor ?

Share this post


Link to post
Share on other sites
would this cause it to lack on power wen the speedo goes off its seems to me as if im driving with no battery the battery light does come on wen the speedo stops working but only wen i come to a stop also where do i find the gear box sensor ?

the gearbox sensor or speed sensor can cause it to stall yes its not that easy to get to and id eget a garage to do it personally

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0