• 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Get Your Club gear
      Get Your Club gear
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Join Premium & Save
      Join Premium & Save
    • Share Your Car Experience
      Share Your Car Experience

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Recommended Posts

Hi my indicators on my dash have stoped working but they still work on the out side also the heated window screen does not work. I've had it in to a auto electrician he's checked the instrument cluster and the fuse bord both fine can anyone help please thanks In advance 

Share this post


Link to post
Share on other sites
 

I remember reading that heated windscreen problems are due to breaks in the filament that runs through it somewhere near the wipers, assuming you've checked that the fuse is ok?

Normal symptom is that one side stops working first though.

As to your cluster issue you are obviously aware that cluster faults were common on the mk2 and usually resulted in the car not starting die to immobiliser problems. My guess would have been a bad solder joint to the trace for the LEDs. I would assume that an auto electrician would have had the cluster out and tested the led circuit to make sure the LEDs haven't been damaged, but also that the trace to the correct pin on the connector is also ok.

Assuming your indicators otherwise work ok, I would have suggested checking the indicator relay.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now