• Share Your Car Experience
      Share Your Car Experience
    • Get Your Club gear
      Get Your Club gear
    • Join Premium & Save
      Join Premium & Save
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Huge Range of Ford Parts
      Huge Range of Ford Parts


bezzawezza

Trip computer (average MPG & speed) resets on starting

Recommended Posts

Having an issue with my wife's Fiesta which isn't big enough to warrant a trip to the garage (I don't think) but is proving to be a minor irritant. Basically when starting the car it will sometimes (probably 1 in 10 or 15 starts) automatically reset the average MPG on the trip computer. Sometimes this will also coincide with a sort of stuttering of the electrics when starting. The car then starts and runs fine so no issues there.
I initially thought, and was told, that this could relate to a dodgy battery starting to go but I've had the battery and alternator checked by a garage who have confirmed and shown me the readings that show that those are working fine.
Does anyone have any suggestions as to what this could be? I've wondered if it is just a fuse but if so I've no idea which one it could be. Should I just be chalking this up as a glitch that doesn't matter or is it a symptom of something more sinister?

Share this post


Link to post
Share on other sites
 

I don't have a decent answer. I have seen this problem mentioned a few times on these forums. I don't recall anyone pinpointing the problem conclusively. More vaguely it could be poor connections on the battery terminals, or at the other end of the earth cable (the negative battery cable)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now