Jump to content


Strutter

Member Since 14 Jan 2010
Offline Last Active Feb 24 2014 02:18 PM
-----

Topics I've Started

Climair Deflectors.

20 February 2014 - 10:34 AM

Hi, just checking these are the right size for a new shape fiesta if someone could confirm?

Seeing as my left one dislodged and blew off as i was speeding down the motorway, driver behind me has great reactions!

 

Mk7 2010 model :

 Ford Fiesta 3 door 08/2008 on Front Window Deflector (pair) 

Product code: 3581 

 

 


2010 Headunit Firmware Update?

18 January 2014 - 04:41 PM

Hi, been having some problems getting my Phone to sync with the BT connection in my car ( Nokia 920), I was wondering if there have been any released firmware updates for these players over the years, and if so, does anyone happen to know where they are available from?


2010 Bluettoth Hu, Profile.

15 September 2013 - 02:41 PM

Hi guys, recently had my phone do an update and it updated the BT firmware on the phone end, but now its not syncing with my HU, never had a problem before and just tried my friends phone and it synced fine.

 

Does anyone know what version of BT that head unit is using?


Anyone Soundproofed/ Deadened Their Fiesta?

16 April 2013 - 03:03 PM

Was thinking of upgrading the speakers but everything points at unless your doing a full system its not really worth it.

 

Only reason I was thinking was im getting some rattles from the front and rear left hand side speakers ( don't think its the speakers themselves, just the housing/ cards vibrating around them.

 

Think the best course of action is to sound deaden the cabin a bit first starting behind the front door panels ( 3dr model) and then getting in behind the rear panels and doing the same.

 

Anyone done this?

 

Also, any guides to removing the rear interior panels for a three door Fiesta?


Wobble Happening In Steering Wheel.

27 March 2013 - 03:53 PM

Just a question as I seem to have developed a rather noticeable "wobble" in the steering wheel that comes a little more noticeable at speed ( about 60) but can feel it starting from around 30.

 

Theirs no sounds coming from any of the wheels, braking seems okay, tread on the tire still looks even.

 

Im thinking it wouldn't be a balance. alignment issue as I assume it would be the tire wear that would be affected and not cause a wobble in the steering wheel?

 

 

Could it be a warped Brake disc?...I have a horrible though that when I try and drive home tonight of seeing the wheel overtaking me on the motorway.