Jump to content


Show

benny

Member Since 23 Jun 2008
Offline Last Active Sep 20 2008 08:51 AM
-----

Topics I've Started

mk4 fiesta

20 September 2008 - 08:48 AM

hi fairly new, was wondering if anyone could help, since ive had my mk 4 fiesta (99) 1.4 zetec, there has been one of those powerboost valves in the engine bay, im getting pretty fed up of it now and want to get rid as its just doing my fuel no justice, i found that it replaces the fuel pressure control valve, is this right?if so whre would i find one for my car, would i be looking at going to a ford dealership?

thanks for any help.

accelerating

23 June 2008 - 09:24 PM

hi there im new to the club and need a little help.

i recently brought a mk 4 fiesta 1.4 zetec 16v t reg (99) and unknowingky did not notcie that the throttle potentiometer sensor was missing with just the 2 screws loosly left in the throttle body. The problem i have had is when cold the car seemed to not meet my demands from me putting my foot down on the throttle, the car doesnt instantly pick up revs, and when driving it takes a couple of seconds to pick up from my demand of the throttle and really judders the whole car when it does finally react, also when the revs were high on the come down the revs would stick at 4000rpm for quite a while until i would keep tapping the throttle, this would happen in neutral and in gear, also the car would backfire quite loudly when the revs were coming down, there is also a flat spot at again 4000rpm when accelerating, but will carry on accelerating quickly after the flat spot. i had someone have a quick look at it as there were 2 items i wasnt quite familiar with under the bonnet, i found out that there had been an aftermarket 'original cast iron powerboost valve' fitted at the rear of the engine bay, which i have been told doesn't make any affect to the performance to the vehicle or saving fuel, i have read up on the item and found that the manufacturer states the part 'offers fuel pressure adjustment via a screw on crown of the unit', also i found an 'ecotek CB-26P valve' ?? I recently discovered the 2 parts in the latest 'fast car' magazine which inclueded the 'ESP design' mag. i was told that if i simply brought a throttle potentiometer that it would cure the flat spot and the sticking at 4000rpm, after purchasing one, i now have a new problem, whilst accelerating i find now at 4000rpm i loose all acceleration and drive, it will not go any further that just over 4000rpm and i take my foot off the throttle and back on and i get nothing, no drive, no gain of revs, i have to change down or up a gear to carry on driving, i have also had instances where he car cuts out altogether when turning the steering wheel at a stand still, or stopping at a junction. i know its a meaty read but if anyone has any clue as to what the problem could be, i would appreciate your comments.

thanks, benny.