Jump to content


Show

ZeEscort

Member Since 03 Feb 2010
Offline Last Active Aug 06 2014 08:34 AM
-----

Topics I've Started

Mk3 Suspension/wishbone Replacement + Rear Coils

05 August 2014 - 07:59 PM

I'm starting to get really annoyed with my car now, I've recently put it through an MoT and it failed.

 

I need to replace both front wishbones/suspension arms and though got the majority of the tools for the job, I'm missing a star drive. Anyone know what size this is?

 

Also is their any good guides on doing the replacement, as some say drop sub frame, where as others say use jack.

 

What replacing the coil springs on the back, I've changed these on an Astra and Volvo is it going to be the same procedure?

 

All help is greatly appreciated.


Making My Mondeo Angry

27 April 2014 - 02:53 PM

I own a Mondeo Ghia X - Duratec 2.5 V6

 

She's not angry enough for me.

 

I believe that V6 | V8 | V12  should sound like the engines that they are (Grunty, Heavey & Angry), not the subtle grunt every now and then. So I'm looking at making mine very angry, I will be modding the car in and out as I'm changing the bodywork to look more like the ST(the car even looks wimpy). I'm already looking into a Dual Cat Split Exhaust system and having the engine cleaned from top to bottom (Ports cleaned and polished, pistons replaced etc). All that will just bring the engine back up to condition, so I need some advice on how to improve from their.


Stolen Plates

17 March 2014 - 06:43 PM

I just want to make people aware, I had my number plates stolen on Saturday 15th March.

 

I know who has stolen them and they have been reported to police as stolen, but if anyone see's these being used other than on an Ford Mondeo Ghia X then it's not my car and so can you report the location where they have been seen and the type of car they are on to the police.

 

PLATE: FN02XMA

 

Cheers Guys.


What Are These Pipe Connections

17 March 2014 - 06:40 PM

I need to replace to what look like "L" connectors, one connects from the MAF to the engine and the other comes from something on top of the engine.

 

Can someone identify the bits I require.

 

This is the connector that runs of the pipe from MAF. You can see the split in that one.

maf_pipe.jpg

 

The pipe that connects from that bit of block

pipe_1.jpg

 

Which is here

pipe_1_2.jpg

The split on this one, is on the bottom connector that connects to the engine.

 

Cheers guys.


Mondeo 2.5 Ghia V6 - Not Starting

05 February 2014 - 05:21 PM

Let me explain this a little to what happened.

 

I was parked at school waiting to pick my daughter up, when the stereo, lights & wipers (Was on at the time) all flashed several times as if loosing power. So I switched ignition off and on again and then thought nothing of it.

 

I then came to start the car and it won't start, it feels like a dead battery as it's not giving out enough power to start (Not getting the woosh from turning ignition) all I'm getting from the ignitions is a one or two clicks and then nothing. Which one would assume that it was a dead battery or starter motor causing issues. Now this is where it gets interesting, as I had been driving the car up until the point of picking my daughter up from school. I even went to shop several times and so "Start & Stop"

 

Now what is interesting is the dials when trying to start the car, I've had this issue with a motor bike doing the same and it was a compression issue that was the cause for the bike. Well when you turn the ignition, the speedo and rev counter needles all hit full whack before resetting to zero when the engine is ready to be turned over.

 

Also another couple of things that I noted as well, my recent millage counter has reset to 0 and so has the gauge for telling me how much fuel is in the tank (It was on 15 miles when I pulled up at the school, as I was going to petrol station after school).

 

So I'm at a bit of an end to what it can be.

 

I've had to leave the car at school as I don't have break down cover and not sure what to do next.