Jump to content


ZeEscort

Member Since 03 Feb 2010
Offline Last Active Oct 31 2014 03:53 PM
-----

Topics I've Started

Loss Of Power

18 October 2014 - 10:27 AM

Ok here I am once again, with some more woes of the Mondeo.

 

So the car went through MoT, but since the MoT I've noticed an issue with performance. Now normally when I hit the high rev range, from 1st through to 3rd I can feel the toque in ranges of 3000 - 5000 and can feel the pull. However in the last couple of days, I've seemed to have lost that toque. I'm at a loss at what it could possibly be and so many thing are running through my head of possibilities that all I'm now seeing is £££££££.

 

So some of the things that I think it is.

 

Clutch:

 

I'm not noticing any slipping with the clutch, or drop downs in power (though on occasion it does a little spit in 3rd).

 

Gearbox:

 

Nothing noticeable from the gearbox, it does have a little left/right shake but it's not dropping out of gear or grinding.

 

Exhaust: 

 

I do have some damage to the exhaust, the sleeve on first section from manifold is not holding in place (Noticed this before MoT). I've not fully checked the exhaust since, but I do get a rattle from it on backend more than what I should do.

 

The only other thing I can hazard a guess at, are things like fuel filter, air filters, injectors and other bits.

 

Anyone else have any input to what could be causing the issue?

 

All the help is appreciated. 

 

As an after thought, I did recently have to top the oil up from almost empty and it's played up since......


Thank You To All

25 September 2014 - 02:56 PM

Just wanted to say a big thank you, to everyone who has helped with advice and other things.

 

The car went through the MOT today, after having a huge amount of money spent on it to get it fixed.

 

So thank you to all those who helped me on my way.


Making Brake Line.

16 September 2014 - 02:20 PM

I'm in the middle of trying to sort out my break lines, as I have various section that are very corroded. I've got 3/16 copper brake line to replace the damaged section, flare kit to create the lines and M/F metric unions.

 

I've been practising flaring the pipe, which I can do really well, especially on a double flare.

 

But the union doesn't seem right to me, can someone advise from the images that I am connecting the union correctly and will hold if it's done this way for the breaks.

 

 IMAG0027.jpg

 

IMAG0028.jpg

 

Cheers.


Mondeo 2.5 V6 Brake Lines

31 August 2014 - 01:49 PM

Does anyone know where I can find some metal brake line, I've got a split in the main line near the rear driver side (This is where both lines for the rear meet). I'm looking at repairing the break, rather than paying for the full lines to be replaced. So I'm after some metal break line tube, does anyone know where I get this?

 

Cheers guys.


Mk3 Suspension/wishbone Replacement + Rear Coils

05 August 2014 - 07:59 PM

I'm starting to get really annoyed with my car now, I've recently put it through an MoT and it failed.

 

I need to replace both front wishbones/suspension arms and though got the majority of the tools for the job, I'm missing a star drive. Anyone know what size this is?

 

Also is their any good guides on doing the replacement, as some say drop sub frame, where as others say use jack.

 

What replacing the coil springs on the back, I've changed these on an Astra and Volvo is it going to be the same procedure?

 

All help is greatly appreciated.