Jump to content



Member Since 21 Mar 2010
Offline Last Active Oct 18 2015 12:11 AM

#489488 Help Hard-Wiring Dashcam

Posted by Chase on 26 May 2015 - 05:15 AM


Sent from my iPhone using Ford OC

#489252 Help Hard-Wiring Dashcam

Posted by Chase on 25 May 2015 - 11:18 AM

Ok, so I have now made a few changes to the camera set up in my Swift.


Reduced the piggy back fuses to 2 amp. Thank you MarkST.


Added a switch so that I now have two power feeds.

1 x permanent live

1 x Switched Feed (Ignition on and engine running)





#457466 Help Hard-Wiring Dashcam

Posted by Chase on 22 February 2015 - 02:33 PM

Hope you don't mind me commenting as I now drive a Suzuki Swift Sport. I loved my fiesta and I hope to get another when my 3yrs are up. I still enjoy reading the Fiesta forums and read your post.
I run 2 Roadhawk dash cams, front and rear from a piggyback fuse holder connected to the fusebox in my Swift. I used one of the spares that have no fuses connected. Usually there is a couple empty that are either switched or permanent live on a vehicle. This doesn't interfere with anything else.
My camera's are covered by a 3 amp fuse in their power feeds that I purchased with the camera's.
So with just the front camera fitted I placed two 5amp fuses into the piggyback holder to complete the circuit and replaced them with two 10 amps now both camera's are running.
I like the idea of the camera's powering on with the ignition but for me, I wanted to be able to leave them on when the car is parked up for a few hours. I therefore fitted them to permanent live with a 12v remote switch so I can turn them on and off manually. The only drawback is having to remember to turn them on when driving. I'm sure the fiesta will have some spare fuse holders if you test with a volt meter.