Jump to content


Show

zev

Member Since 24 Mar 2010
Offline Last Active May 27 2012 06:31 PM
-----

Topics I've Started

Ac Not Working

26 May 2012 - 05:21 PM

Hi all. I've had my focus for couple years and never really tried the AC. It doesn't appear to be working. I switch on the AC with blowers and cool air does come through but only cool air not like it should when on AC . Can the AC be re- gassed. I don't know anything about the ac because this is my first car with the option.
Thanks guys

Anti Freeze

01 January 2012 - 12:35 PM

Hi , Happy 2012 to you all hope you all have a wonderful year.
I'm confused about my anti freeze. My original anti freeze in my car is the OAT which is a sort of fluorescent orange/pink colour. I bought a ready mixed bottle from Halfords which is same colour, I bought another one the other day from T.M.S which is described as OAT, but is more of a red colour and not fluorescent. I'm confused now is it still ok to use as the colour is differant. If your wondering why I'm buying so much its because I have a leak, my mechanic tells me my external pump is faulty. I am having a new pump next month when my bank balance has gotton over Christmas.
zev :D

Water Level

08 August 2011 - 09:56 AM

Hi all I'm here again. I've just topped up my water level. My question is how often should it be topped up as I only did it a couple months ago. This could be normal for the focus. My last car was a vectra and I topped it once a year.
Zev

Exhaust Smell

07 August 2011 - 09:30 PM

Hi all need advice. My focus has been smelling of gas lately mainly on a cold start. The car is performing ok. I've never come across this before any ideas of what this problem may be.
Zev

Master Cylinder

01 June 2011 - 04:53 PM

Hi all, need some advice. I had a small drip of fluid in the drivers footwell. I took it to the garage and they said its the master cylinder that needs replacing. All seems ok now. But I've noticed my focus is using a lot of fuel. Not accurate I know but I used the fuel gauge to give me an idea of my fuel consumption. I put 18 litres in and it did 120 miles around town, this is very poor. I did it again to make sure I had done it right and it was roughly 125 miles on 18 litres. Any ideas why this may happening. it wasn't doing too good before the repair but its gone worse.
Zev