Jump to content



Member Since 07 May 2010
Offline Last Active Aug 19 2012 06:01 PM

Topics I've Started

Heater Blower Resistor Unit

16 October 2010 - 02:03 PM

Hi Guys and Gals

The heater blower on my 52 fiesta 1.4 diesel only works on setting 4 so it looks like a problem with the resistor unit. Does anyone know the location of this unit please? A picture would also be good.



Hi All

07 May 2010 - 01:39 PM

Hi everyone

Just joined today.

Got a red Fiesta 1.4TDCi on a 52 plate which just keeps on going....and going.....and going :D

Usually very reliable in other words. It has developed an annoying problem with the speedo which I've explained in a post in the technical area so any help there would be great.

Looking forward to chatting with all you other like minded Ford owners



Speedo Drops To Zero

07 May 2010 - 01:34 PM

Hi Folks

I have a Mk6? I think Fiesta 1.4TDCi on a 52 plate and it's developed an annoying habit over the past few months. The speedo drops to zero randomly. Sometimes it will pick up again after a few minutes other times it will stay at zero for ages. This means I'm not registering mileage either. Can someone tell me where the speedo is picked up from. I've looked in the Haynes book of lies and general untruths but it only shows the ubiquitous chip on the instrument cluster with no clues as to where the speedo feed comes in. I presume it comes off the gearbox somewhere and I'm guessing it's a bad connection that makes and breaks. Any good steers as to where to look would be useful. Thanks