Jump to content


itsrelfy

Member Since 14 May 2010
Offline Last Active Today, 12:17 PM
*****

#402415 Mini Cooper Wouldn't Start

Posted by itsrelfy on 28 August 2014 - 07:55 AM

Hi all

Don't know if anyone could help me she's any light in this.

Went out in my fiancés 2004 mini yesterday to get it cleaned then take it for it's mot. When we got to the car wash ( one of those hand jobbies) we switched off and waited until they had cleaned it and then got back in and it wouldn't start just a clicking noise.

So straight away I thought battery. Anyway the guys there helped me to bump start and it fired straight up.

Drove to it's mot in town and had no more starting issues.

Went to eurocar parts and picked up a new battery then travelled to my folks house 20 mile away. Borrowed my dads multi meter and it showed 12.5v. Went to install the new battery which incidentally didn't fit as it wasn't tall enough so the cables didn't fit on the terminals.

So reinstalled new one and the voltage was still good. Fired it up checked voltage whilst running and it showed 14.5v

So I know it's not a ford but do you think it could be a faulty starter motor or something else?

Any thoughts?

Cheers
Adrian.


#387252 New Oil Filter

Posted by itsrelfy on 18 July 2014 - 12:55 PM

That's the same one as I got for my 1.6tdci. If you look under the turbo and down towards the ground you will see a black plastic cap with a 27mm nut on top. You need to unscrew that and the filter is in there.

It makes life easier if you remover the black air hose that goes into the turbo.


#359140 Some Issues With My Focus

Posted by itsrelfy on 01 May 2014 - 08:54 PM

I use she'll or esso fuel. Not the expensive stuff just normal diesel but I don't use supermarket stuff.

As for the phone I'll give it a try tomorrow.

Thanks