Jump to content


Member Since 04 Aug 2010
Offline Last Active Jul 03 2015 02:02 PM

Topics I've Started

Time To Say Goodbye

29 March 2015 - 06:04 PM

So After 8 years of driving Fiesta's the time has come to move up, just ordered a Volvo XC60.


The Volvo Forums are no where near as active as this one and I wanted to take this chance to thank everyone who over the years has been really very helpful, I will always love Ford as my first car, fine the dealer service is a shambles but I do not expect much more from Volvo to be honest.


The only last thing now is to try and sell my fiesta, my local dealer offered less than Volvo which I though was rubbish I am considering we buy any car or similar, I would like to sell privately but cannot be doing with the hassle of it to be honest.

Major Drop In Mpg On 1.6 Tdci

04 February 2015 - 07:25 PM

Hi all
The last few months I have noticed mpg dropping for example on a trip to London where before I got 70mpg I only got around 60, also on my normal commuting just filled up and have an actual usage of 49.5mpg, in 4 years I have never seen it drop below 50 including when much colder than this.

It was serviced in September and has only done 2.5k miles since, has anyone else ever had such a radical drop, no relevant codes on forscan.

Upgrading 2010 Sony Head Unit To Dab

24 November 2014 - 12:00 PM


I know this has been discussed many times but because the word DAB is short no search seems to turn up what I want to know.


I have a 2010 Sony HU  in my titanium, it was one of the first of the line on the MY that included the Sony stereo, if I want to upgrade the unit to DAB what is involved, I know that there are 3 separate components, the buttons, the main unit and the screen, I have the dot matrix but white/ blue display, is it possible to upgrade that at the same time to the colour version or is that only for Sync?


Thanks all,



Climate Control Question

16 November 2014 - 07:46 PM

Hi All,


Wondered if anyone had come across this before,


My EATC on auto mode does not set the fan to any speed regardless of the temperature, sometimes the Hi and Lo will cause it to go to max but not always.


There was a fault code on the system 


B10EA 0x90EA Positive temperature coefficient heater


Not sure if it is connected but it was doing it once or twice before but now seems to constantly do it, have forscan and could not see a huge amount on it that looks wrong but I am no expert.


Has anyone else heard of this issue and if so any suggestions on what is wrong,



Recall On Tdci Fiesta

15 November 2014 - 09:36 PM


Just wanted to let you guys know had a letter from ford today that my car has been recalled for a Glow Plug controller or something not being water proof and that it is powered constantly so there is a risk of fire.

Cannot find any reference but if you have a 2010 95ps TDCI you may have a letter soon.