Jump to content


Show

matty2008

Member Since 10 Nov 2008
Offline Last Active Jun 21 2009 06:04 AM
-----

Topics I've Started

st 170 exhaust

17 June 2009 - 03:54 PM

hi,

the exhaust on my 2002 st170 has just gone right at the front. i popped it in the garage thinking it would be a quick cheapish job. but the garage has phoned saying no stocks exhausts for this model except the main ford dealer. ive just phoned them and they gave me a price 370 + VAT just for the front section!!!!!!! has anyone else had this trouble? or does anyone know where i can get a cheap one from??

any help or advice would be welcome.

thanks

st170 clutch probelms?

10 February 2009 - 04:00 PM

hi, my st170 has just developed bit of a problem. i think the clutch is on its way out, but me, not knowing anything about cars, thought i better check with some people that do.

the other day i was pulling out of a busy junction, so i gave it some revs and let the clutch out whilst in 1st gear and tried to pull out into a smallish gap in the traffic, which normally wouldnt be a problem, but ended up accelerating out the junction ridiculously slow with the rev counter practically on the redline, resulting in bit of a burning smell and lots of light flashing and finger gesturing from the guy who nearly ran into the back of me

if it is the clutch, does anyone have any idea how much it might cost, or is there any upgraded clutch i could get that doesnt cost the earth??

thanks

focus wing mirror

29 November 2008 - 08:22 PM

hello,

i've just had my wing mirror smashed off and i've been pricing up new ones. i've got a 2002 st170, on the internet all the sites i've looked have either manual ones, or electric and heated ones. i didn't think mine were heated though. does anyone know if you can get electric ones that aren't heated??? or have just never noticed that they are actually heated.

i was also wondering if anyone here has fitted one? i don't want to put it into a garage if i can help it and was thinking about having a go myself

"sensitive" engine management

10 November 2008 - 02:25 PM

hello,

i bought a 2002 st170 nearly 3 months ago. ever since i got, the check engine light keeps coming on. whenever i take it back to the garage where i got it from, they keep telling the computer is saying there's nothing wrong with it and that the engine management system is just very sensitive(which i find hard to believe!). i was wondering if anyone else has had similar problems?

also i'm 100% sure that the air conditioning pump it running perminantly as well, the switch works fine and the light on the switch go on and off ok, but it blows out freezing cold air even when it says its off. i've mentioned this to the garage as well and they said that the computer would be able to tell if that was the case( which i also find hard to believe!!) do anyone know if the air conditioning is connected up to the fault finding thingy?