Jump to content



Member Since 04 Sep 2011
Offline Last Active Nov 29 2015 09:23 AM

Topics I've Started

Clutch Help.

28 October 2015 - 08:52 PM

Hi one and all.

I've been having a lot of fun today striping down the ka today ready for the new year track fun, however in the mean time when I went to move the car back into its resting place down the side of the house the clutch pedal had no resistance at all so I ended up pushing the car. 🙄

Before this happened the clutch bite point was literally a inch off the floor.

Forgive the armature question but is it the clutch that's gone or is it something like a cable or linkage that's come loose?

This is my first car project so I'm trying to learn as I go! 😀

Project Ka

25 October 2015 - 11:49 PM

Hi everyone!

I've recently bought a ford ka (2005 1.3) for £50 from my brother in law with the intentions of turning it into a little go cart to go around the track with, the car it self is in decent shape it needs new bumpers as they've seen better days, the interior isn't the best as he's a builder so sadly it's seen its fair share of rubble and dirt. (Not that it matters as I'm pulling it all out any way in the name of weight saving.)

Now I know I'm not going to get much power out of the 1.3 lump but I may well
Go down the puma 1.7 convert road in the new year.

I am in need of some advice, there is something wrong with the clutch in regards of the bite point it's literally 1 inch off the floor and I'm no mechanic in any means but any advice what to start looking at would be amazing!

Thanks in advance!