Jump to content


aland

Member Since 04 Oct 2011
Offline Last Active Feb 23 2014 02:28 PM
-----

Topics I've Started

Starting Problem

13 October 2012 - 05:18 PM

I have an X reg Mondeo Mk 2 ? version (reg Sep 2000) just refused to fire up. It cranks over fine plenty of welly in battery but will not fire up. Had a simillar problem back in May when again it would not start. It was very hot day and car had been for a long run. After leaving it for about 20 mins came back and it started (ie fired up OK). Felt like the old problems with vapour lock which I didn' think you get nowadays with modern cars.. I was confinced it was a fuel related problem! Pump maybe ? However it did it again couple of months later. But this time I left ignition switched on for a couple of mins before cranking and the egine fired up no problem. Yesterday went to start engine from cold and although it would crank over again battery was good it refused ti ignite. Called RAC out but was unable to pinpoint exact problem. His laptop didn't work so was unable to get a fault code, He thought it was a crankshaft sensor ? Fuel was OK i.e plenty of petrol not diesel! Fuel was not getting to injectors.Tested the pump but it was running OK. Had to get it towed to my garage. Still awaiting diagnosis result.
Has anybody had similar experience and got any suggestions or results. I am rather mystified ?

Water Under Carpet In Passenger Footwell

30 August 2012 - 07:36 PM

I have an X reg Mondeo (Mk 2) and have discovered water under the carpet in passenger footwell. I have checked and sealed the pollen filter housing so its not coming from there. I am suspecting that the (2 plastic and 1 rubber) grommets in floor pan are the culprits.Perhaps they have aged and contracted letting water past the seal. I just can't think where else the water is coming from.Its definitely coming from underneath car and not from the top down as I have rubber mats.I am going to dry it all out (the insulating felt is sodden and stinks like hell, which is why i looked under carpet in first place!) and smear loads of silicone sealant over it. The air con has been switched off and can eleminate any blockage in drain hole. So I don't think its that. There is a lot of water so I don;t think its the air con. Has anybody else had problems with these stupid grommets ?.