Jump to content


Show

DC1982

Member Since 08 Oct 2011
Offline Last Active Apr 07 2013 01:45 PM
-----

Topics I've Started

Replaced Injectors Poor Mpg?

04 April 2013 - 07:43 PM

Hi

 

54 plate Mondeo 2.0 tdci 115.

 

Due to smoking and erratic idle and some flat spots I spent £700 on getting the 4 injectors refurbed and recoded.

 

The car started perfectly this morning and drives smoothly and pulls well but for some reason my mpg is worse now than before the injectors were replaced???? I didn't think that there would be a need for them to bed in or anything as they have just been recoded but am I wrong?

 

Can anyone explain why the MPG after a 1hr run on the motor way at 75mph would only be 42mpg????? I was geting 47-50 with the knackered injectors!

 

Cheers all


Squealing Brakes!

28 July 2012 - 12:57 PM

Hi, I have a 54 plate Mondeo tdci.

I changed the pads a few weeks ago, used decent pads and plenty of copper grease to lube. Brakes squeal very loudly now, noise generally stops when applying the brake, Have checked pads again today no issues - have even wear, discs are fine, plenty of copper grease and no brake dirt as I cleaned them up before.

Please can someone help as the noise is both driving my crazy and is embarrassing? Read some topics around handbrake cables or rear calipers being faulty causing to much pressure in the system? Anyone got any ideas?

Thanks

Temperature Gauge Help!

31 May 2012 - 04:06 PM

Hi Guys

Mk3 TDCI (115)

Temperature gauge was showing erratic readings - would take ages to get to normal operating temperature then would drop down back to 60c and then just keep moving between 60 and 90c.

I have changed the thermostat and the cylinder head sensor and changed the coolant but problem hasnt gone away - No idea what else it could be short of the actual dash display being faulty ?

Any ideas?

Thanks