Jump to content


Show

pragmatix

Member Since 16 Nov 2011
Offline Last Active Nov 14 2012 12:35 PM
*****

Topics I've Started

Long Run Mpg Not A Tale Of Woe

15 April 2012 - 05:25 PM

Just back from Chetsey and got these figures didnt think they where too bad ,585 miles,at an avg of 51.2mpg, avg speed 66mph, not bad for an old Mondeo Estate 130 Tdci

How Cars Used To Be

09 February 2012 - 07:52 PM

After reading the no windscreen washer warning thread it struck me that I have survived cars not only without a washer warning system but also no washers so I started compiling a list in my head about things on the cars of my youth
Bench front seats (Austin Cambridge)
3 speed gearboxes with column change ( Standard Vanguard)
Optional heaters (Austin A35 and plenty of others)
windsceen wipers that went slower the faster you went (Ford Popular)
Trafficators )The arm things that stick out the side of the car) and switch on the dash ( Ford Popular )
Foot operated dip switch Great bit of kit ( various )
45mpg (Hillman Imp, Citroen GS)
No Syncro mesh ( various)
Grease nipples on moving parts ( all )

Im sure there are more, not saying that it was the golden age of motoring, but it was certainley more involving, oh and you could fix them with a couple of spanners.
The downside they where not as reliable, points to check, decokes to do, etc

Brakes

15 January 2012 - 11:54 AM

Not sure if its just me but my brakes work, but dont inspire confidence, not sure if that because I have come from a Citroen C5 ( fantastic Brakes) or if Mondeo brakes are just dead. Cailper are all clean, pads are newish not glazed, discs in good condition and as of half an hour ago fresh fluid and bleed, pedal solid, so is it just the car? its a 2002 130 Tdci estate

Hesitation On Part Throttle

06 January 2012 - 03:02 PM

I have an annoying problem on my 2002 tdci 130, after been on the overrun and if I apply light throttle as oppsed to booting it I get a missfire, that feels like the engine is going to stop, then it picks up if I give it some gas.
Definately feels like fuel related but I dont have a clue as to where to start, drives fine apart from that, no warning light or anything

Hi

16 November 2011 - 09:22 PM

Hi All,
Ive just joined the forum, I have just purchased a Mondeo 2ltr Ghia X estate my first road going ford, used to rally a Mexico years ago.

Ive had a look around and it seems a good site, hope I dont need to much advice from you all

Pete