Jump to content


Show

mk3pain

Member Since 22 Jan 2012
Offline Last Active Nov 04 2012 05:32 PM
-----

Topics I've Started

Mk3 Escort In Need Of Help!!!

04 November 2012 - 11:44 AM

Hi all basically id like to pick all ur brains concerning trying to get my crossflow to run! i had a new rebuild back in febuary and i dropped the engine into my car back then with help from a mechanic he wired up the dizzy and coil and done all the silly bits but we left the rad ect loose just to get the engine started.... however it had alot of trouble trying to start i undertsand it was new and it probably is tight but the compression coming from it is rediculous! i was sort of thinking the starter motor wouldnt have enough beans because it would turn over 2- 3 times then give up all together, since then i left it there due to moving ect.. i have recently started putting time and money back into it, i had a set of bike carbs jetted and a manifold made from bogg brothers, stuck electric fuel pump on and completed all wiring and silly bits i didnt finish bk in febuary e.g rad, fan, fuel pump.... i done all of this yesterday and yet i was still having the same problem, the engine just wasnt turning over quick enough even with a new battery and my mate in hes jeep jumping it also... we checked the plugs they all have spark, theres defo petrol getting to the cylinders as we took the plugs out and could smell it on the tips.. the dizzy as far as i know is right as it was put in by a mechanic even so ive been told it would start with the dizzy out by a few degrees but would just run like crap... i have now come to a brick wall as i dont know what else it could be any help or suggestions would be GREATLY appreciated,

Regards a sad mk3 owner :(

Need Carb For Crossflow Engine

22 January 2012 - 10:18 AM

Hello all just a brief introduction my name is roy i have a mk3 escort 89 wich has a new rebuilt mk1 xr2 crossflow engine dropped in and i finally got the chance to hear it try to start yesterday but failed miserably and im not sure why, i have a new distributor + coil wich was fitted and is all in workin order as i have a spark its manual petrol pump wich wont feed the carb as the engine wont run so i tried to force feed the petrol through the carb and still had no joy so im not sure wether the carb is buggered as i brought it off ebay for £12 only solution i can come up with is to buy a new carb and see how that go's but that is turning out to be a problem in itself as i need a manual twin choke dft and i cant find 1 any where even burtons dont sell it, if a new carb fails to work does any1 have any ideas as to why it wont start? many thanks regards roy.