Jump to content


Show

LexxLizz

Member Since 16 Feb 2012
Offline Last Active Feb 16 2012 10:00 PM
*****

Posts I've Made

In Topic: Help!! Suspected Alternator Problem, Now Told It's Electrical...

16 February 2012 - 06:05 PM

PMSL!!! It does... For now...
I do hope that's what the problem was and a week down the line my alternator doesn't decide to throw a curve ball. Think I was asking for trouble giving my car the name of a notorious Gangster all those years ago... :huh:

In Topic: Ford Speedo

16 February 2012 - 05:29 PM

I'm always told by friends, speed warning signs and my sat nav that mine under-reads (KA). But how would you know for sure if it actually does??
This is something I've always been curious about.

In Topic: Help!! Suspected Alternator Problem, Now Told It's Electrical...

16 February 2012 - 05:21 PM

Thanks for the replies guys...

Right! Progress. Leccy guy says there was a break behind my fuse box which has been fixed AND a common fault in Ford KA's is for the plug which connects to the alternator to corrode. This had corroded and dropped off -- chap said all the guy at the first garage had done was shove the wires back in the terminals; which is no good to anybody (apparently) and is certainly not a permanent solution as the wires will just keep dropping out - causing the flickering, so this is why it was running off my battery. Said although he's not a mechanic, he's confident my alternator is fine as my car would have cut out at least a handful of times by now.

Says I also need a new plug now and for him to fit it correctly.
He said this should sort the problem and would tie-in with the issues I've been having.

He has quoted me £60 for the job.
Not gonna have Ronnie Kray back til tomorrow though... :(