Jump to content


fintious maximus

Member Since 08 Mar 2012
Offline Last Active Jun 09 2013 08:54 AM
*****

Topics I've Started

2.0 Petrol Egr Valve

09 June 2013 - 07:24 AM

Decided to attempt a clean of the EGR valve yesterday to try and resolve the hesitation at 2000 revs so folowed the guide.  Got the easy bolt out with no worries but couldn't get the rear bolt (towards back of car) off - how on earth do you get a socket or spanner in that tight gap?

 

Any suggestions would be most welcome - I gave up and put it all back together and replaced about a litre of coolant but don't like to be beaten so will try again......


Front Wheel Hub Nut Loose

23 January 2013 - 05:15 PM

Hi all,

Took my car for its MOT test today and it failed on front wheel bearning having excessive play. (I take cars to local council garage who do not fix cars,only test them!). I thought it was a bit odd as I only had a new bearing and drive shaft fitted a few months ago. Anyway, got it home and in the garage and jacked it up to have a look. Turns out that the hub nut was loose so I have tightened it up and now the 'excessive play' has been cured. My question is - should the hub nut have a locking device as cars I have worked on before have always had a split pin to hold it tight.

Incidentally,I only tightened it up with a spanner so will get a socket - think it's a 32mm if anyone can confirm?

Leak - Looks Like Water/power Steering Fluid?

20 January 2013 - 11:16 AM

Hi all,

Can't get under the car to look properly as i'm on crutches at the moment. My 2.0 petrol has a smallish puddle under it (towards front of engine on drivers side) which seems to be a mix of water and redish fluid. I've had to top the power steering reservoir up but not coolant reservoir. Any ideas what this may be? It's in for MOT on Weds and would like to sort before if possible.

Slight Hesitation At 2000 Rpm

21 July 2012 - 07:48 AM

Hi all,

Just looking for some advice please. Car hesitates slightly at 2k rpm. I've changed plugs, leads and coil pack but it's still there - even tried another coil pack though admittedly not a Ford original. Is there anything else that could be causing this niggle? Also changed fuel filter!

What Are Symptoms Of Failing Leads/coil Pack?

07 July 2012 - 12:28 PM

Hi all, replaced plugs,leads and coil pack about 3 months ago as the car was juddering a bit. Bought bits on Ebay and last week the car has started to judder a bit when holding at around 2500rpm. I'm thinking rubbish leads or coil pack but wanted to see what you thought before I buy better ones.

Someone suggested it may be the dreaded swirl flaps on their way - are they similar symptoms?

Thanks in advance