Jump to content


Majic

Member Since 09 Mar 2012
Offline Last Active Jan 25 2014 08:32 PM
-----

Topics I've Started

Replace Seatbelt Anchor (Rear Passenger Side) 2010 Focus

22 January 2014 - 01:45 PM

I have a faulty seatbelt in a 2010 Focus that won't allow you to buckle up. There is nothing wrong with the belt, the fault is with the stalk/anchor (button bit)

 

How to I go about replacing this? Do I need to replace the belt as well? I bought a second hand anchor from a breakers yard which comes with a belt attached to it. So do I have to fit the belt as well. Has anyone got a link or some information as to how I go about this. I thought you just had to replace the anchor but now I'm not sure

 

Many Thanks

 

 


Seat-Belt Problem Focus

31 December 2013 - 02:56 PM

I've got a problem with one of my rear seat-belts. I have to press the orange button at the same time as pushjing my seat belt into the socket else it won't work.

 

There is nothing wrong with the belt itself just the socket bit.

 

I've tried WD40 but to no avail. What is the best way around this? Do I need a new socket part and is this easy to sort out?

 

My car is a 2010 Focus Zetec.

 

Many Thanks


Cannot Open Bonnet On Focus Mk3 300+Repairs!

31 August 2013 - 08:14 AM

I have a 2010 Ford Focus (mark 3 ). Yesterday my car went in for a service and the garage were unable to open the bonnet. After a couple of hours of trying with a screwdriver after reading a guide on here we gave up and took the car to our local Ford dealer.

 

They quoted me the following:

 

New Grey grill (as you would have to break the old one)  £35

New lock £41

New Latch £60

New Clip £3

Build Lock £29

Labour at £96 per hour (!!)

VAT

 

We're talking over £300.

 

Is there another way around this. Could a non-Ford dealer repair this at a cheaper price or would they not be able to get the parts. Also would there be a problem with the lock as I don't want to pay for new keys.

 

Any help greatly received.

 

When trying to open with a screwdriver we pushed at the white plastic piece under the bonnet but this did not budge at all.


Warranty Confusion/repair Advise

06 March 2013 - 02:10 PM

I bought a 2010 focus last month that still had 6 months remaining of it's 3 year warranty. After driving the car I noticed the following issues:

 

1) None of the 2x12v Sockets in the car work.

 

2) The light in the boot compartment doesn't work

 

3) There is a whistling sound present down the driver's side when reaching speeds of 40 mph+

 

I rang my local dealer and booked the car in as I explained it was still under warranty. It was only when I turned up that they said none of the above would be covered and I would have to pay. I left at this point.

 

Assuming they are correct, how can I repair 1)  and 2) (I assume 3 will be more difficult)

 

Is it a fuse/bulb issue?

 

I have no handbook in the car so wouldn't know which fuse to change.

 

My car is a 2010 Focus Zetec 1.6 (Petrol).

 

Many Thanks