Jump to content


civil-zz

Member Since 28 Mar 2012
Offline Last Active Mar 26 2015 12:08 PM
*****

Posts I've Made

In Topic: Guide For Focus Mk2/mk2.5 C-Max/kuga ~Elm 327 Cable And Ff2 Program

26 March 2015 - 11:24 AM

emerald293, your issue isn't linked with PATS initialization or smth similar. just issue with elm327 adapter or computer performance. on these modules type (SID206, correct?) PATS init procedure MAY be required only when to update to some calibration levels. if process gets stuck on memory erasing stage then it means that adapter just can't get an answer on erasing command, there is no about PATS. best way is to change your ELM327 adapter. also changing connection speed or USB driver delay could help.

one more point - if you was able to upload your original file then it means that modified file also can be uploaded. second point is whether it can be started after but it can be flashed into the module. seems that you equipment just works unstable.


In Topic: Guide For Focus Mk2/mk2.5 C-Max/kuga ~Elm 327 Cable And Ff2 Program

04 February 2015 - 05:41 PM

giorgiodav,

battery voltage should be enough and central lock should be unlocked


In Topic: Guide For Focus Mk2/mk2.5 C-Max/kuga ~Elm 327 Cable And Ff2 Program

10 January 2015 - 12:51 AM

RB2004

understand your point, many thanks for the explanations!

when i investigated this issue i found out that the st/rs and kuga have many differences in PCMs, such as for example security keys or memory addressing. at the same time st and rs are the same regarding these points. also st and rs can have the one module from the same set of bosch modules, here are their numbers:

0261209048
0261209096
0261209468
0261209476
0261209482
0261209483
0261209484
 
but no of them can be installed on kuga, it can have only next:

0261209354
0261209397
0261209471
0261209472
0261209473
0261209474
0261209533

 

so i thought that this is the cause of situation why i can't read the kuga module and can't flash the custom calibration into it via obd. and was sure that st and rs are completely the same and there should not be any issues with rs. seems that i was mistaken..

 

troy45

you need to take the latest ELMConfig version (0.2.15), it has a tick on Page 1 of configuration marked as a steering menu availability.

107e3faac0e1t.jpg


In Topic: Guide For Focus Mk2/mk2.5 C-Max/kuga ~Elm 327 Cable And Ff2 Program

08 January 2015 - 11:27 PM

RB2004

what security are you talking about? did you try to flash stock RS module or after some firmware modification, for example from revo etc.? for my understanding the programming principles are the same on kuga, ST, RS. I flashed the kuga and ST but i have no RS modules in my own so the only attempt was to read the calibration from revo vehicle - without success, when I requested the memory address module answered with NRC 31 - request out of range.. what will happen if to take the stock RS and try to enter the programming mode, pass the seed request and give a command to erase and flash firmware?


In Topic: Guide For Focus Mk2/mk2.5 C-Max/kuga ~Elm 327 Cable And Ff2 Program

30 December 2014 - 10:16 AM

The most focus RS were reflashed in the plant to a newer SW, and I think that is why they has always the dummy VIN WF0WF0...

In Germany i think The Most Tuner also add the Basic ST SW on the PCM of the RS that they get Access to it. Maybe that could also be an Route cause why the VID is complete incorrect?


Would it be possible to add an digital speedometer into the Cluster SW?

oh, thanks for the information, i didn't know about VINs..

no, SW change can't lead to VID change because they are located in different memory areas. i still can't understand whether i can't properly decode VID or it was corrupted. but last assumption means that RS software doesn't see to VID data and it's values doesn't matter :)

to add a digital speedometer there is total cluster firmware change is need, this option was not put by engineers. 

 

SERGEY, Can the ELS27 unit be purchase outside of Russia, if yes can you Please provide the sellers name or link.

here is the site - http://els27.ru/

but unfortunately it doesn't work temporary due to some hosting issues.

here are contacts of developers and sellers

http://ffclub.ru/user/59450/ (ittrium)

http://ffclub.ru/user/182443/ (Digital-Cj)

 

i connect my MK2 FOCUS with elm, by using elmconfig 0.2.3 older version 

 

now i want to connect with elmconfig 0.2.15 ,but it get an error :(

 

AT S1 error

AT S1 command is need for newer version proper work. seems that your chinese clone doesn't support it..