Jump to content


Show

Chrispy.

Member Since 14 Apr 2012
Offline Last Active Private
-----

Topics I've Started

Engine Sludge Removal

23 June 2012 - 07:51 PM

I recently shattered my tensioner, which caused my timing belt to slip which then cause my pistons to bend my inlet valves.
I took it to my Mechanic - Martin - who fixed it all. but when he took the head off, he noticed it was full with black sludge like fluid.
He said "This car has not had a good life"
He said it may have missed a few services.

He pressure washed the head clean from the sludge which has improved the performance of the 1.4 Zetec SE engine, however he has said i will need to clean the rest of the engine.

My question is, has anyone used a Engine Flush treatment? if so, what will be the best one to get?
Have you ever had to remove sludge? if so, how did you do it? and how is your engine now?

Ive got new oil and oil filters ready for the numerous changes to clean the engine, but Martin has said use a Engine Flush.

Any Ideas?

Posted Image

Engine Management Light 2003 Mk 6 Fiesta Se

30 April 2012 - 09:31 AM

Hey!

My Place of Work is 20 Miles away from home, drive there - Fine! Drive home, problems.
It seems that when i get half way home, the Clutch Pedal shows vibrations.
When i push down on the clutch, more vibrations occur
If i accelerate, more vibrations occur and the car sounds 'Rusty' or 'Diesel-ish'
It also seems to have lost abit of power.
I recently completed a full Service which cleared the issues, however they seem to be back.

The Engine management light has come on on the dash, i took it to a garage where they said it could be the oxygen sensor, he reset the light as he couldn't find anything wrong with the car.

It has been a month since this happened and the light has come back online, since then, same symptoms have occurred.
Since taking it to the garage, and today, I completed a full Service which cleared these issues, however they seem to be back.

I have also noticed the Car will sit in idle at 1.5k revs on some occasions.

I have had many people saying it could be sensors, the CAT, I was think it could be the clutch slipping, hence the lack of power and vibrating when i compress the clutch?

The car has done 77k miles, last recorded service was @ 60k miles.
Last MOT was in October.

Any Ideas?
Chris

Best Engine Oil?

18 April 2012 - 12:14 PM

Hi!

I need to complete a full Service on my Fiesta Special Edition 1.4 2003.

I was wondering what is the best engine oil to use. and how much it is :)

Any Ideas?

Thanks!
Chris