Jump to content


Show

rivnog

Member Since 25 Apr 2012
Offline Last Active Apr 09 2014 08:34 PM
-----

Posts I've Made

In Topic: Glow Plugs For 1.8Tdci

09 April 2014 - 08:38 PM

surely then much accept some responsibility. But how you get them to pay or do the work is another matter...

 

I had escort tdci 1998 the cam belt shredded the teeth, breaking the cam shaft etc 

 

So I had a local firm put a new head on the engine and I was back up and running

 

Then one day I decided to change the plugs only to find 1 was broken off in the head.....great and thanks guys!!!!

 

I got some metal fabricators that were working onsite one day to weld a nut on the end of the snapped glow plug but that just twisted off..

 

In the end the car ran well for another 10,000 miles and then I got shot of it

 

I not sure if driving on 3 plugs is bad for your engine, I'm sure someone will let us know... I'm also sure someone said that the compression is enough the ignite the diesel fuel but I don't know if that correct.

 

all the best and good luck


In Topic: Glow Plugs For 1.8Tdci

05 March 2014 - 08:27 PM

Different engine bay to mine. I think you will find your glow plugs under the oil filler plastic. I can see the injectors so your plugs are near by, there is one per cylinder 4 linked together with 1 red wire which bolts down to each glow plug.

In Topic: Hey Ho

01 February 2014 - 08:36 AM

Good point

Are you actually from Maldon?

I was born in Maldon now in Tollesbury

In Topic: Clutch Pedal Only Came Up Half Way

10 January 2014 - 11:12 PM

I now put this problem down to a knackered battery. I think on starting up the battery wasn't turning the engine over quick enough and the glow plugs could not function correctly. Since fitting a new 76 amp battery both the shaky start and cold start issues have now been sorted


In Topic: Glow Plugs For 1.8Tdci

10 January 2014 - 10:56 PM

So I did my glow plugs back in December 2012 hoping that it would short out my cold starting problem but it didn't.

So now in December 2013 my battery started to fail. After much hunting and research I changed the old 72amp battery to a 76amp model which has now completely fix the problem. I got the battery from Ebay for I think £46 delivered