Jump to content


Show

segana

Member Since 21 May 2012
Offline Last Active May 23 2012 11:51 AM
-----

Topics I've Started

Ford Focus Tdci Loss Of Power In All Gears

21 May 2012 - 08:56 AM

Hi All,

I'm having a few problems with my Focus TDCI 1.8 and all the searches I've done come up with similar but perhaps not exact issues, so I thought I'd ask the people that would know.

Whilst my GF was out and about in my Focus, she began to lose power in 5th gear, so she stopped, called the AA and a guy came out and said it was the EGR valve so he fitted a blanking plate. He apparently told my GF that he was "supposed to inform her" to get it looked at as soon as possible, however she should have no problems running with the plate fitted.

This initially solved the loss of power issue and the car ran great for a while. Due to incredibly limited funds (new baby just been born), I've not been able to get the car to a garage to take a look.

However on Saturday, the curse of the GF struck again. On her way back home, the car started to lose power again, however this time in all gears.

I've managed to take the car out for a short run this morning to see what she was on about and there is an incredibly noticeable loss of power in all gears. It takes much much longer to get up to speed (I can get up to 60-70, but it takes a good 10 seconds longer than normal maybe to get there). The engine sounds fine (I'm no mechanic though lol although it's revving much higher to get up to speed). Plus there's NO black smoke coming from the rear, no warning lights on the dash and no knocking or other abnormal sounds, just a real loss of power. I also asked the GF, her dad & brother, who had been in the car at the time, if there had been a bang at all before the powerloss and they all said no.

Before this happened, a friend suggested removing the blanking plate and using something like Wynn's EGR cleaner or 10k Boost to clean through the intake system as he said the EGR had likely just got clogged and stuck.

What I'm asking is if anyone has a good idea as to what the issue could be? And also if they think that giving the car a good blast with a cleaner might at least be worth a shot before taking it to a possibly costly garage?

Everything I've read so far suggests that the Turbo could to be ok due to no bang/black smoke and that the issue could possibly now be poor air flow or a split pipe to the turbo?

Any help and suggestions are greatly appreciated :)

Matt