Jump to content


Show

tayn

Member Since 29 Jun 2012
Offline Last Active Jul 01 2012 06:32 PM
-----

Topics I've Started

Focus Tdci 1.8 Red Warning Light, No Power

29 June 2012 - 10:16 PM

Hi all,
1st (half decent) ford iv owned, got to say its a great car :) i usually go for audi/bmw/vw but fancied a change!
anyway got hold of this little guy, tdci 1.8 (think its a sport) had a full ST replica done, seats bodykit rims dash trims pretty much everything, and a matt black finish looks pretty good!
anyway been running alright for about 2k, then 3 days ago stalled on me (i was giving enough revs) and a light came on, on the left in a cog shape with a ! inside. didnt think nothing of it as it went away thought maybe it was like another version of ESP or sumin i dno.
anyway 2 days later same thing, stall light on, this time i had to turn off and on to reset. now today it happend, im noticing its usually when i pull of quickly, today was reversing, going into 1st gear and pulling off. this time the light will not go, and iv noticed since its been on i have next to no power, i struggle to get to 30 in 3rd gear without having to do 4000+ rev. and definetly will not go above 40 without sounding like its 100!
my mechanics more german car orientated so hes not sure, havent had a chance to get him round to run faults yet probably wont for few days. my mate who is a focus owner also thinks either camshaft sensors or the EGR valve going a bit mad, but does anyone know the exact problem or had this before?
any help would be ideal :(
thanks
tayn