Jump to content


Show

Wayneo01

Member Since 18 Jul 2012
Offline Last Active Oct 10 2013 10:38 PM
*****

Topics I've Started

Plastic Cover Under The Engine

15 July 2013 - 06:38 PM

Hey guys

Just had a look under the car and The splash guard (think thats what it is called) under the engine has come loose and its scratching everytime i go over a speed bump, i can phsyically move it up and down. How are these held on is it just with clips? a link to some clips which would help would be very much appreciated.

Regards wayne

Alloy Help

27 April 2013 - 07:45 PM

Hey guys my 15 spoke titanium alloys have buckled, im not going to be buying the same 15 spoke again. Was wondering which ones would be the better choice because i still want ford alloys but just ones less prone to buckling. I have a 2009 titanium

Option 1 -
http://www.fordonlin...662_F1817662-23

Option 2 - http://www.fordonlin...618_F1817618-62

Trolley Jack

17 March 2013 - 05:06 PM

Hey guys

Believe its about time to change my front wheels with my rear. Only thing is i dont really know how best to do it, ive done it before on previous car but on this one i cant seem to find the best jacking point.
I can see the sills where you would put a normal fiesta jack but ive gor a trolley jack with axel stands, so me trying to use my trolley on that would probably bend them.

My jack
6094e4f4d977dad863151e2b302013a3.jpg

Pothole Fun

15 March 2013 - 06:12 PM

This morning while driving to work hit a massive pothole, passangers front tyre. Starting pulling to the right so went to get my wheel alligned and they said it was +8 off( not to sure what that means). I only had time to do the allignment and couldnt check if anything was broke, anyways everytime i turn right i feel like my car is going over pebbles.

I know the obvious answer is to change my route so i only have left turns but sometime a man needs to go right.

Anyone think what it can be.

Help To Find A Part :)

19 January 2013 - 06:16 PM

Okay guys had a look under the bonnet today and noticed that little yellow clip which keeps the hood rod keepy up the boonet in place is broken so it is not staying clipped into place. I cannot find reference to this part anywhere haynes manual or internet, anyone got any idea what part code it is.

Cheers wayne