Jump to content


Show

Frank89

Member Since 05 Aug 2012
Offline Last Active Aug 17 2012 05:51 PM
-----

#198939 Ford Fiesta Mk7 Headunit - Ipod Track Navigation Not Working

Posted by Frank89 on 05 August 2012 - 10:13 AM

Hi all, long time reader first time poster. Recently bought myself a Ford Fiesta MK7 edge and it's fantastic in each and every way :-)

There is one minor gripe though which I'm hoping you guys may be able to help me out with........

When I plug my iPod into the headunit using the USB cable, I can listen to music from it with no problem and can scroll from track-to-track, but cannot navigate between albums/tracks/artists etc using the built in menu. Instead of being presented with a selection of 'Artist', 'Album', 'Genre' etc. - all I see is 'Track 0'. There are no other options.

Unfortunately, this means I need to unplug my ipod and select the album of my choice before I start driving or use the AUX cable instead (which doesn't charge it up when driving).

This ipod menu navigation did used to work but just stopped one day for some reason; is this a common problem which can easily be fixed as I've never heard about it before. I've also tried another ipod with it, but am experiencing the same problem. Given this, the fault is with the headunit. (FYI It's the built in one but without handsfree bluetooth capability.)

I'll probably take it into my nearest service center soon for them to have a look at it (as it's still under warranty) but is there anything else I could try before I do this? Many thanks.