Jump to content


zahtar

Member Since 21 Sep 2012
Offline Last Active Oct 22 2014 10:09 AM
-----

#393969 Air Filter Age

Posted by zahtar on 04 August 2014 - 05:20 PM

If the receipt of the service center has an air filter billed, then I wouldn't go back to the same center, as they would be clearly robbing their customers. If the service receipt (or report) is not in with your car, ask the previous owners if they still have it.

Having said that, the service center that I go to, does not replacs the filter each year. They "check it visually and replace it if necessary". I had been taking it out and blasting it with an air compressor, so during the first three years it remained in better condition as yours, so they didn't replace it until the third service. Of course they did not chrage me either.

sent from my foolphone using tapatalk!


#375173 ! Guide ! Installing Rear Parking Sensors To Fiesta Mk7

Posted by zahtar on 16 June 2014 - 08:10 AM

That's exactly what I guessed of too!

Keep us posted mate, good luck!


#210496 ! Guide ! Installing Rear Parking Sensors To Fiesta Mk7

Posted by zahtar on 09 October 2012 - 07:25 PM

Ok guys and girls, I bought a set with four sensors, with a small led indicator that has a built in buzzer. It takes power from the reverse light as many other parking sensor units. I installed it and took some pics to share with you my experience in case it is of any help. English is not my mother language, so plz excuse any mistakes. Please be warned that this procedure involves work below the car, so make sure you do this 100% safely.

Step 0: Painting the sensors to your car's color. (Optional)

As another member advised, it is best to paint the sensors with a spray paint, and a spray clearcoat. This will make your sensors look nicer in the end. Unfortunately I did not follow this advice. I used the ford's touch up kit to paint the sensors which I ended up to rerget. From a close distance they look a bit sloppy, but from 2 steps away it looks fine. A technician mentioned that the spray coat should be very thin to ensure that the sensors work normally, but the brush I used probably applied a thick coat. My sensors were designed to allow being painted so this is something you should also take into consideration when buying your set. Another thing to think of is for the sensor cables not being permanently attached to the sensors. Not a must, but I think it could have served me better.

Step 1: Measuring and marking

I applied paper tape on the bumper so I could mark with my pen easily and protect it from any accidental scratches. Considering the boot clip being the middle of the car, I counted symmetrically from it. 20cm to the left (mark B ), 20cm to the right (mark C). From these two, I counted 40cm towards the sides, left side having mark A, right having mark D. That means all of them have a distance of 40cm from each other. All of them are marked at a height of 55cm from the ground.

IMG_2111b.jpg

Step 2: Drilling (this can really get to you)

I used a puncturing tool to work on the marks a bit, so the drill finds it way correctly without sliding a cross the paintwork scattering chaos all around (this is a BIG BIG warning!). I wasn't able to puncture the bumper, bit it was a good start for the drill. (yep, this is a really dirty car!)

IMG_2112b.jpg

Do not force the drill in the hole, it will find its own way, Hold the drill steady moving slowly and horizontally. The slower you do it, the smoother the hole will be. Notice all the black plastic shreds around the hole. This is normal. While opening the two central holes, the bumper vibrates a lot and makes a really loud sound. This sound is almost heartbreaking. If you love your car too much, detail it too much, and are afraid to hurt it, hearing this will be a real challenge for you. I was using the drill carefully so I did no damage. There is a decent gap behind the bumper so you won't reach the metal if you don't force things.

IMG_2114b.jpg IMG_2115b.jpg

The holes are really neat and you can also tell this from the drilled parts.

IMG_2131b.jpg IMG_2143b.jpg

Step 3: Installing sensors

Before installing any of the sensors I marked their connectors with A,B,C,D as the sockets in the main unit. This helps identifying which cable is for which sensor when connecting to the main unit. On second thought, that was not really necessary, as you can tell which is which by the length of the cable that reaches the main unit (the longer the cable, the closer the sensor is).

IMG_2117b.jpg

Insert the connectors first, reach from below to the inside of the bumper and pull them all the way in. Before you secure them, keep in mind that some sensors are oriented. Mine had an “up” mark to specify this. What the Ford electrician told me was absolutely true; in the inside of the bumper there are some clips where you can route the cables!

IMG_2118b.jpg IMG_2124b.jpg

Step 4: Routing the cables inside the boot.

First you need to remove bottom and side carpet. I could not totally remove the side carpet, but completed the installation without issues. To move the side carpet, locate the two plastic bolts (do you call these grommets?) as shown in the pic. One is shown, the other is symmetrical.

IMG_2125c.jpg

Put your fingers between the plastic and the metal and pull towards the front of the car. They come off completely with a normal difficulty which I like very much cause it means they will be steady afterwards too (ok, they will indeed become loose if you use them too much). The rest of the plastic comes off by pulling it upwards (vertically) releasing 4 metal clips. I did a little damage here, even though I was really careful :( I used flexible super glue to fix this.

IMG_2126c.jpg

Pull out the side carpet as much as you can, to reveal the holes and the cables powering the rear lamps (upper side part of the boot) and the fog lamp on the bumper (lower side, just below the others). The fog lamp is powered via a cable which goes down through a rubber seal. This is where you will run the sensor cables through. The Ford electrician advised this entry because its not on the same side as the exhaust. Keep in mind that this is the rear left of my car, which has a left steering wheel. Don't know if everything is symmetrical in UK, but the thing is to keep the cables away from the exhaust.

IMG_2130b.jpg

The four sleek cables are from my sensors, the curly one is from the fog lamp. You will have to carefully puncture a hole through this rubber seal as I did. Feed all the cables through this (from below the car towards the boot) and afterwards seal the new hole with silicon glue or whatever. Forgot to take a pic from below the car, but it is really easy to identify the curly cable and open this seal. The seal is not glued on the hole, it is removable and secures nicely. Once you have fed the cables though, stabilize their part that is below the car with tier ups (or whatever), so there is no danger of them being caught anywhere. Do this and the work below the car is complete.

Step 5: Wire connections

A while ago, when you moved aside the side carpet, you revealed the holes and the cables powering the rear lamps (upper side part of the boot). You will need now to bent inside and find this connector.

IMG_2127b.jpg

It has a push pin which releases if you push it upwards. No click, it comes off really smoothly. I think it only clicks when plugging in. Notice in the next image the two cables which I have drawn apart on the right. They are the blue and the black/purple. Sorry for being out of focus.

IMG_2128b.jpg

The blue connects to the + of the parking sensor power supply (red for mine) and the black/purple connects to the – (black for most I guess). My dad helped me stripping the wires and connecting the unit's power wires there as I just described. Insulating tape was applied to separate each cable. Additionally, a pair of tier ups was set on each cable so that the tape doesn't dry and go away after some time. Overkill? I do think so, but my dad insisted that this was the best way to be sure in the long run. Better safe than sorry...


IMG_2129b.jpg

Plug the connector back in place (push pin was downside) and connect the cables to the main unit to test the sensors. As someone posted earlier, you can put in the reverse gear without the engine running, in order to power up the parking sensor. Walk behind your fiesta and listen to the buzzer, look at the display leds etc. If they all work correctly, one thing remains. And that is cable management inside your boot, behind the side carpet. I routed the supply cable and the sensor cables through some gaps that allow me to have everything in my boot. The unit came along with double sided sticky tape, but I had a velcro sticker which works nicely on the carpet. Finally I placed the led indicator behind the seats of the rear passengers with velcro stickers as well. This way I can see it either through the mirror or directly if I turn and look back. I realised at a later point that the led indicator is designed to be looked at when facing forward. The way that I put it behind the passengers seats, gives mirrored readings. This means that if there is an obsactle on the left corner of the bumper, the leds for the right side will be flasing. This can probably be fixed by swapping the cables. I'll connect cable A to socket D, B to C, C-B, D-A. I have tamporarily left it as it is, cause the buzzer sounds anyway, so I know when I am about to touch something ;)

IMG_2133b.jpg IMG_2135b.jpg

And the exterior result.

IMG_2141b.jpg

Thanks for reading, any comments or improvement suggestions are welcome :)