Jump to content


john j

Member Since 01 Nov 2012
Offline Last Active Sep 13 2013 05:26 PM
-----

Topics I've Started

Clutch Peddle

23 August 2013 - 08:59 AM

Hello members, has anyone had to remove/refit clutch peddle on a Fusion such as when clutch master cylinder needs replacing. I had to replace this on my fusion. And it was extremely difficult to get clutch pivot bolt back in because of the spring that is attached to master cylinder and clutch peddle. There are nylon locator bushes that slot in both ends of steel pivot bush and I actually damaged them triying to get pivot bolt in. Is there an easier way of doing this job ?

Clutch Switch

21 August 2013 - 09:18 AM

Dose anyone out there no exactly what the purpose of the clucht switch is ? Its situated under the dash in the footwell. When u push the peddle in to disengage clutch it releases and when u let clutch peddle out to engage clutch the clutch peddle arm comes up and pushes plunger on switch in again

Notchy Gears

06 August 2013 - 08:59 AM

I have a Fusion 1.4 TDCI 03 reg which has done 174k. Gear selection is generally more difficult with all the gears. Particularly first , reverse and changing down from 5th from high speed when engine is hot. I recently had to have a brake pipe replaced at the n/s front brake. I wonder if air managed to get into the clutch hydraulic system as they both have a common reservoir filling cap. Has anyone out there had simular problems ?

Fusion Turbo Oil Feed Maintenance

11 May 2013 - 01:33 PM

I have a 03 1.4 fusion. Which has covered 170,000 miles. I have been told that the turbo oil feed pipe and banjo bolt filter can become blocked and the turbo can break up and wreck the engine. Should the oil feed pipe be cleaned regulary and the banjo bolt be replaced often. Does anyone out there know about this

Temperature Guage

29 December 2012 - 10:41 AM

I have a 03 fusion 1.4 tdci . Its got the led temperature guage. Later models came with propper dial guages
Quite often when I have only covered a coupleof miles from cold this guage flashes on and off and is accompanied by a red temperature symbol (thermometer in water).
This lasts for a couple of minutes and then everything goes back to normal. This dosent happen when the engine runs further and is up to full working temperature. Does anyone know what is going on here?