Jump to content


Show

Big Lib

Member Since 11 Nov 2012
Offline Last Active Nov 27 2012 10:54 AM
-----

Topics I've Started

'08 Fiesta (Mk7) Engine Management Trouble!

11 November 2012 - 08:28 PM

First problem was the main 'Engine Warning Light' (the amber light in the shape of an engine) was on solid. Found a faulty spark plug, the centre anode was flopping about, never seen anything like it. Job done or so I thought. The next day with a loss of power the other engine management light came on, (amber exclamation mark in a circle) :(.

Fortunately when the engine was turned off reset and it was fine. Had it checked out but could not find anything because it was reset! Said he had known about a fault with the accelerator plug which he'd taken off checked and replaced but if it continues, it must be a sensor problem and recommended a garage.

Nothing happened for weeks but when the fault reappeared I cleaned the plug again and it seamed ok. I got myself a DTC reader.
When the fault reappeared I read all the faults wrote them down and cleared them to compare to future DTC's logged. This didn't happen for months. Now it's happening regularly I've plugged in my reader only to find there are no DTC's logged? I even managed to get the fault with the reader plugged in but although the reader is telling me there is a fault there are no DTC's logged? <_<

After reading some Bloglines this weekend noticed some talk of a possible Lambda sensor fault?
Sorry about the lengthy story, any thoughts? :huh: