Jump to content


Show

trigger

Member Since 31 Jan 2009
Offline Last Active Apr 22 2013 08:48 PM
-----

Topics I've Started

Exhaust Smoke And Glowing Red. Help

01 July 2011 - 08:04 PM

Hi. I have a 2007 S-Max 2.0l TDCI with 25000 miles. After a 2 mile run I noticed a small lack of power from the engine. When I got home I made sure the handbreak was off but I then noticed a oil burning smell coming form the back of the car. After looking underneath the car I saw the exhaust just behind the first box was glowing red with heat!!!! I turned the car off and then smoke started coming from the outside of the exhaust all the way down and from the engine bay. There is no sign of any oil leaks anywhere on the car. Any help of what it could be before I hand over my house deeds to Fords..

Sat Nav/ Radio Fault

15 June 2011 - 09:41 PM

Hi all, My sat nav unit has just started to play up. Its a CG3537 unit(the touch screen one) in a 57 plate s-max. some days it will turn on and all is fine then other days it lights up as if it was turning on but nothing comes up on the screen and no sound. Any ideas on what this could be???? Thanks inadvance.

Owen

Sat Nav/radio Fault

15 June 2011 - 09:39 PM

Hi all, My sat nav unit has just started to play up. Its a CG3537 unit(the touch screen one) in a 57 plate s-max. some days it will turn on and all is fine then other days it lights up as if it was turning on but nothing comes up on the screen and no sound. Any ideas on what this could be???? Thanks inadvance.

Owen