Jump to content


Andyr16

Member Since 04 Dec 2012
Offline Last Active Dec 31 2012 09:00 AM
-----

Topics I've Started

Focus 1.6 Tdci 109Bhp Losing Power And Stalling

04 December 2012 - 04:40 PM

Hi Guys

I have a Focus 1.6 TDCi Zetec on an '06 plate that has in the last 3 days developed a problem, when accelerating in 2nd or 3rd gear and the engine has gone over 3k revs the car seems to just lose all power and comes to a stop and the engine stalls, whenever this has happened I've pulled over and in turning the steering wheel the only error message I'm getting is 'Power Assist Steering Failure'.

Any ideas? I've not had chance to pull the air filter yet, and not replaced the fuel filter so wondering if one of them a cause thinking it's air or fuel starvation), it's also due for it's 125k service, just can't afford right before Christmas to put it in.

t runs fine if I don't let it hit 3k revs, short shifting etc. I had a similar issue on my Mk1 Tddi where it was the throttle pedal wearing out and every 115 miles it would go into limp mode.

On this car though this morning it happened on a roundabout after pulling off, so after restarting I tried my 3k theory and that out it into stall. Only had the car 5 months and got the dealer to replace the turbo as original replacement had a flaw in the casing, so not sure what to do now. Should also point out it starts back up fine and runs fine after restarting.

Any help or advice will be greatly appreciated as don't want anything to happen when I have my two young kids in the car with me.

Thanks
Andy

Focus Tdci 1.6 '06 Plate Losing Power And Stalling

04 December 2012 - 01:14 PM

Hi Guys

I have a Focus 1.6 TDCi Zetec on an '06 plate that has in the last 3 days developed a problem, when accelerating in 2nd or 3rd gear and the engine has gone over 3k revs the car seems to just lose all power and comes to a stop and the engine stalls, whenever this has happened I've pulled over and in turning the steering wheel the only error message I'm getting is 'Power Assist Steering Failure'.

Any ideas? I've not had chance to pull the air filter yet, and not replaced the fuel filter so wondering if one of them a cause thinking it's air or fuel starvation), it's also due for it's 125k service, just can't afford right before Christmas to put it in.

t runs fine if I don't let it hit 3k revs, short shifting etc. I had a similar issue on my Mk1 Tddi where it was the throttle pedal wearing out and every 115 miles it would go into limp mode.

On this car though this morning it happened on a roundabout after pulling off, so after restarting I tried my 3k theory and that out it into stall. Only had the car 5 months and got the dealer to replace the turbo as original replacement had a flaw in the casing, so not sure what to do now. Should also point out it starts back up fine and runs fine after restarting.

Any help or advice will be greatly appreciated as don't want anything to happen when I have my two young kids in the car with me.

Cheers
Andy