Jump to content


chrispy

Member Since 02 Feb 2009
Offline Last Active Feb 06 2009 03:40 PM
-----

Posts I've Made

In Topic: Fiesta from hell

06 February 2009 - 02:05 PM

hi .i just read about your problem. it sounds to me as if theres water going into your air inlet and getting through the filter into the engine. and thats why its chugging.
hope this helps

In Topic: 15" alloys on standard fiesta without any mod?

02 February 2009 - 09:35 PM

hi i have a mk 5 and ive got 16" wheels on. if your changing your wheels just go to your nearest wheel shop and ask what the biggest wheel is that you can fit on.
hope this helps ;)

In Topic: Fiesta Mk5 Alloys and Front Grille??

02 February 2009 - 09:25 PM

hi ive got a mk5 and ive got 16" oz star fives on with 195/40/r16 tyres on and ive never had a problem with rubbing
ive also done the grille
if you detach the grille , you will see on the back that there is some clips, if you push these clips in the three layers should just seperate, then cut the mesh to fit and then just place the mesh in the middle and clip the layers back together and put it back on the car
jobe done
hope this helps.

In Topic: Performance Mods?

02 February 2009 - 09:17 PM

hi ive just read all of your comments on the chip for the fuzzy. ive bought a +15bhp chip from celox performance on ebay.
ive had it in for about 1500 miles now and it has drastically reduced my fuel consumption which is good as i travel a good distance to work. it also seems to give more acceleration and ive got a mk5 1.3. and i feel a difference so i dont really think it matters about the engine size. :)