Jump to content


jmeader

Member Since 15 Dec 2012
Offline Last Active Dec 16 2012 11:22 AM
-----

Topics I've Started

Intermittent Loss Of Indicators And Heater Blower

15 December 2012 - 10:16 AM

Ive just had a garage "fix" this problem that lasted a week before it returned

They said they replaced the relay behind the steering column which they said was very awkward to access because it was right up behind the dash

I found a 2amp glass fuse left on the passenger footwell and im wondering if this points to something else that was actually done instead of changing the relay which would mean ive been ripped off

I wondered if i should attempt to remove the relay myself and confirm with ford if its the original or aftermarket as ive had the car from new and i know this has never been replaced before

The loss of indicators and heating is a total failure usually after the engine has been off for a while and returns with no warning or with me aggrevating it by turning the heater blower on between 1-4 speed or moving the indicator stalk up and down

My hazard lights work and the indicator lights work on the dash despite the actual indicator stalk not working

The 2 problems are directly linked and fail at the same time every time as i have tested this theory by leaving the indicator stalk up or down and the heater blower on a speed of 1-4 and they both magically come back on at random points

I have also noticed a loss of heat that started to happen a few days ago and was noticable before it went into the garage

I hope this is enough of a description and im keen to hear your thoughts especially about whether you think the relay the garage supposedly changed has any bearing on the original problem and especially how an indicator relay can be anything to do with the heater blower?

Prior to this problem the garage said they fixed a coolant leak by changing the water pump, theromostat housing and another major part which all resulted in a bill of 410.00