Jump to content


Show

IMMO

Member Since 31 Dec 2012
Offline Last Active Jan 14 2013 07:24 PM
-----

Topics I've Started

Engine Management Warning Lights

31 December 2012 - 02:54 PM

We love our car (2005 on a 54 plate C-Max 1.6 TDCi Manual Zetec) but we have had an unresolved engine management issue with it since the middle of 2012. The engine management warning light came on (on Friday 13 July!) and immediately the car lost all power with a system failure message. The car was eventually taken to our local Ford dealer when our usual garage was unable to even start the car. Ford were initially unable to diagnose the problem as their diagnostic equipment kept on throwing up several fault codes including instrument cluster failure. The pcm and wiring cluster was checked cleaned and car reassembled and all seemed OK and nothing was replaced. This cost us £489.41 in labour. The car then started misbehaving a month later (losing power, speedo falling to zero and recovering, engine warning light on) and then they replaced the accelerator pedal sensor (FOC) after much complaining. Now at the end of the year, the problem has reappeared, and this happened after I drove in torrential rain and through several slightly flooded sections of road. The warning messages we are getting include, 'Limited Speed Mode, 'Steering Assist Failure', the Speedo fails occasionally and the car will lose power momentarily when we are decelerating which is really scary, but then pick up again. Ford have in all fairness tried to sort the problem out so no real complaints there. Does have anyone have any suggestions?