Jump to content


Show

sjs

Member Since 07 Feb 2009
Offline Last Active Jan 19 2010 08:50 PM
-----

Topics I've Started

Mk6 1.4 eating catalytic converters

10 April 2009 - 10:27 AM

Hi, i have a 2003 i.4 zetec fester.

The engine light illuminated a few months ago and was diagnosed by GK Ford Carlisle as having a blocked cat, we had a cat fitted supplied by TMS motor spares, about a month later the light has come back on and Ford have diagnosed once again a faulty cat, is there any common faults with the mk6 that would cause it to damage cats i.e. running rich etc, it does use a very small amount of oil but nothing other than normal usage, it had new lambda sensors, plugs and ht leads when cat was fitted, it's currently on very thin ice as we've had it 4 months with nothing but trouble!, cheers.

Fiesta van poorly sick.

24 March 2009 - 08:41 AM

Hi, my mk5 1.8td van is having a bad day!
2001/51
27,000 miles
regularly serviced, due in May

I was driving it last night through the backroads round home in 5th and boxed down to 4th and it just lost power as if the clutch was slipping but only had half revs, if it was the clutch it would have been all revs and no go but it was half revs and no go!. I pulled over a popped the bonnet to find the fan going but i had only been on the road 5 minutes!, stopped engine and restarted and all was ok, does this point to something electrical?, thanks

Steering wheel question.

13 March 2009 - 08:51 PM

Hi, does anyone know if a 2007 fiesta steering wheel will fit a 2003 mk6 fiesta, also are there any common faults with the speedo on a mk6 as mine has gone off it shows no speed and no mileage, cheers

Removing window regulator mk6?

04 March 2009 - 05:13 PM

Hi, does anyone know how to remove the regulator on a mk6 3door as i need to replace the window regulator, i have the panel off i just can't see how to get the inner panel out that holds the reg, cheers

Mk6 Problems

07 February 2009 - 01:58 PM

Hello, i recently bought a 1.4 mk6 Fester on a 03 plate, the car runs and drives great but has developed a few problems in the 2 months i've had it, any help would be great,

Washers only work if stalk button is pushed in hard and wiggled up and down, (possibly just stalk).
Battery light has come on dash whenever driving in any condition, (motorway or backroad),
Centre console moves with gearlever,
N/S window makes a loud crack when putting down from very top, (silicone spray),
Washer jets leaking between bonnet and jets, (leaking onto engine),
Headlight adjusters on all the time, (dipped beam way too high),
Power steering very noisy, (normal p/s noise but 10 times louder),

Has anyone experienced any of these probs before, are any of them common, thanks again, Steve